acm_畅通工程2

题目:

Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。<br>
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。<br>当N为0时,输入结束,该用例不被处理。<br>
 

Output
对每个测试用例,在1行里输出最小的公路总长度。<br>
 

Sample Input
  
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
  
  
3 5 <div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div>Hint</div> Huge input, scanf is recommended.
 

想法:直接用prim算法。。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define inf 0x3f3f3f3;
int mat[11000][11000],dis[11000],mark[11000];
int prim(int n,int sta)
{
    int i,j,flag,sum = 0;
    for (i = 1;i<=n;i ++)
    {
        dis[i] = mat[sta][i];
        mark[i] = 0;
    }
    mark[sta] = 1;
    for (i = 2;i<=n;i ++)
    {
        int min = inf;
        for (j = 1;j <=n;j ++)
            if (!mark[j] && dis[j] < min)
                min = dis[j],flag = j;
        mark[flag] = 1;
        sum += dis[flag];
        for (j = 1;j <=n;j ++)
            if (dis[j] > mat[flag][j])
                dis[j] = mat[flag][j];
    }
    return sum;
}
int main()
{
int m,n,i,a,b,t;
    while(cin>>n&&n!=0)
{
for(i=1;i<=n*(n-1)/2;i++)
{
cin>>a>>b>>t;
mat[a][b]=mat[b][a]=t;
}
m=prim(n,1);
cout<<m<<endl;
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值