poj 2253

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

这道题要求最小的最大值,就是要求青蛙每一种跳法中最大跳板的最小距离.

所以这道题可以用djst或者用floyd变形做,只需要把之前djst存的为源点到该点的最小距离给改成从源点到该点最大跳板的距离(这个距离应该是当前最大跳板距离,和选中的点的最大跳板距离,和选中点到该点的跳板距离中的最大值)就行了,然后每次贪心继续贪最小的,保证当前取到的点是最小的路径.

以下是floyd的:


/*

 * =====================================================================================
 *
 *       Filename:  acm.c
 *
 *    Description:  
 *
 *        Version:  1.0
 *        Created:  2015年03月24日 12时50分51秒
 *       Revision:  none
 *       Compiler:  gcc
 *
 *         Author:  Dr. Fritz Mehner (fgm), mehner.fritz@fh-swf.de
 *   Organization:  FH Südwestfalen, Iserlohn
 *
 * =====================================================================================
 */
#include<stdio.h>
#include<math.h>
#define MAX 0x3fffffff
#define MAX_SIZE 1005

double dist[MAX_SIZE][MAX_SIZE];
int count = 1;

void init(double a[][2], int n)
{
        int i= 0, j;

        for(i = 0; i < n;i++)
        {
                dist[i][i] = 0;
                for(j = 0; j < i; j++ )
                {
                        dist[i][j] = dist[j][i] = (a[i][0] - a[j][0])*(a[i][0] - a[j][0]) + (a[i][1] - a[j][1])*(a[i][1] - a[j][1]);
                }
        }
}

double max(double a, double b)
{
if(a>b)
return a;

return b;
}

double min(double a, double b)
{
if(a>b)
return b;

return a;
}

void floyd(int n)
{
        int k, j, i;
        for(k = 0; k < n; k++)//k为中转跳板
                for(j = 0; j <n; j++)
                        for(i = 0; i<n; i++)        
                                dist[i][j] = min(dist[i][j], max(dist[i][k], dist[k][j]));//原来floyd挑选从i到j的全部选法(k)中的最短距离,现在是挑从i到k,从k到j中最长跳板距离,更新i到j最长跳板中的最短跳板距离!

            printf("Scenario #%d\nFrog Distance = %.3lf\n\n", count,sqrt(dist[0][1]));
        count++;                             
}

int main()
{
        int n;
        int i;
        double a[MAX_SIZE][2];

        while(scanf("%d", &n) && n)
        {
                for(i = 0; i<n; i++)
                        scanf("%lf%lf", &a[i][0], &a[i][1]);

                init(a, n);
                floyd(n);
        }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值