新学期 新生活

新学期已经开始了!
尽管我很不想不想来学校,但是没法避免。
这学期要更加努力学习C++,要让自己的成绩好看一点哦。
第一节实验课

  1. Give you two strings a, b, determine whether string a contains the string b.
    Input Format
    The first line contains a integer n, represents the number of tests.The next n lines contain the n prolems.Each line contains two strings a , b.
    Output Format
    For each problem,if A contains B, output”YES” ,
    otherwise output “NO”(without quotes)
    Sample Input
    2
    abcab abc
    aabbc ac
    Sample Output
    YES
    NO
    Hint:
    请使用c++来完成这个题目
    读入输出使用cin cout (使用 iostream库)
    字符串使用string类型。(使用string库)
    判断包含关系使用string的find函数,以及string::npo
#include<iostream>//标准输入输出流
#include<string>

using namespace std;

int main() {
    int n;
    cin >> n;//输入流
    while(n--) {
        string a;
        string b;
        cin >> a;
        cin >> b;
        string::size_type position;
        position = a.find(b);
        if (position != a.npos) {
            cout << "YES" << endl;//输出流
        } else {
            cout << "NO" << endl;
        }
    }
    return 0;
}
#include<iostream>
#include<string>
using namespace std;
int main() {
    string a, b;
    int t;
    cin >> t;
    while (t--) {
        cin >> a >> b;
        if (a.find(b) != string::npos) {
            cout << "YES" << endl;
        } else {
            cout << "NO" << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值