HDU 5113 Black And White(深搜+剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5113点击打开链接


Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 4041    Accepted Submission(s): 1103
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
   
   
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
   
   
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 
深搜+剪枝的题 只需要输出一种 

如果剩余没填的方格小于最多剩余颜色的两倍 就不能保证相邻的颜色不同 这是本题的关键
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include<algorithm>
#include <math.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <queue>
#include <stack>
using namespace std;
int n=0;
int m=0;
int k=0;
int num[26];
int flag=0;
int a[6][6];
void dfs(int x,int y,int sy)
{
    
    if(x<=0||x>n||y<=0||y>m||flag||sy<0)
        return ;
    
    for(int i=1;i<26;i++)
    if((sy+1)<num[i]*2)
        return;
    if(sy==0)
    {
        flag=1;
        printf("YES\n");
        for(int i=1;i<=m;i++)
                {
                    printf("%d",a[1][i]);
                    for(int j=2;j<=n;j++)
                        printf(" %d",a[j][i]);
                    printf("\n");
                }
        return ;
    }
    for(int i=1;i<=k;i++)
    {
        if(((a[x+1][y]!=i&&a[x-1][y]!=i&&a[x][y+1]!=i&&a[x][y-1]!=i)&&num[i]&&!a[x][y]))
        {
            num[i]--;
            a[x][y]=i;
            dfs(x+1,y,sy-1);
            dfs(x-1,y,sy-1);
            dfs(x,y+1,sy-1);
            dfs(x,y-1,sy-1);
            a[x][y]=0;
            num[i]++;
        }
    }
    return;
}
int main()
{
    int t=0;
    int ca=1;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=1;i<26;i++)
            num[i]=0;
        for(int i=1;i<=5;i++)
            for(int j=1;j<=5;j++)
            {
                a[i][j]=0;
            }
        flag=0;
        scanf("%d%d%d",&m,&n,&k);
        for(int i=1;i<=k;i++)
            scanf("%d",&num[i]);
        printf("Case #%d:\n",ca);
        if(m==1&&n==1&&k==1)
        {
            printf("YES\n");
            printf("1\n");
        }
        else
        {
        dfs(1,1,n*m);
        if(flag==0)
            printf("NO\n");
        }
        ca++;
        
    }
}

又写了一遍。。格式问题wa到死 格式问题也不是pe

#include <bits/stdc++.h>
using namespace std;
int n,m,k;
int cnt[30];
int mmap[10][10];
int flag=0;
int book [10][10][30];
int num=0;
void dfs(int row,int clu)
{
    if(row==n+1&&n!=0)
    {
        printf("YES\n");
        for(int i=1;i<=n;i++)
        {
            printf("%d",mmap[i][1]);
            for(int j=2;j<=m;j++)
                printf(" %d",mmap[i][j]);
            printf("\n");
        }
        flag=1;
        return ;
    }
    for(int i=1;i<26;i++)
    if((num+1)<cnt[i]*2)
        return;
    if(flag)
        return ;
    for(int j=1;j<=k;j++)
    if(book[row][clu][j]==0&&cnt[j])
        {
            book[row][clu][j]+=1;
            book[row+1][clu][j]+=1;
            book[row][clu+1][j]+=1;
            cnt[j]--;
            mmap[row][clu]=j;
            num--;
            if(clu==m)
                dfs(row+1,1);
            else
                dfs(row,clu+1);
            num++;
            cnt[j]++;
            mmap[row][clu]=0;
            book[row][clu][j]-=1;
            book[row+1][clu][j]-=1;
            book[row][clu+1][j]-=1;
        }
        return;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int step=1;step<=t;step++)
    {
        flag=0;
        memset(mmap,0,sizeof(mmap));
        for(int i=0;i<=10;i++)
            for(int j=0;j<=10;j++)
                for(int l=0;l<=30;l++)
                    book[i][j][l]=0;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<=26;i++)
        {
            cnt[i]=0;
        }
        for(int i=1;i<=k;i++)
        {
            scanf("%d",&cnt[i]);
        }
        num=n*m;
        printf("Case #%d:\n",step);
        dfs(1,1);
        if(flag==0)
        printf("NO\n");
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值