POJ - 3190 Stall Reservations (优先队列)

32 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3190点击打开链接

Stall Reservations
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7375 Accepted: 2621 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.
排序 然后从左到右遍历 如果当前队列顶有奶牛已经完成挤奶则把他的场地编号赋值给当前奶牛同时pop   然后当前奶牛入队 如果没有或者队列为空则新创一个场地给当前奶牛

注意最后按编号输出 因此编号也要在结构体中记录 因为special judge因此答案不唯一

#include <stdio.h>
#include <queue>
#include <algorithm>
using namespace std;
struct anss
{
    int nnum;
    int num;
}ans[100000];;
bool cmp1(const anss &a,const anss &b)
{
    return a.num<b.num;
}
struct xjy
{
    int l;
    int r;
    bool operator < (const xjy &r) const
    {
        return l>r.l;
    }
    int num;
}a[100000];
struct xjyxjy
{
    int rr;
    int nnum;
    int num;
    bool operator < (const xjyxjy &r) const
    {
        return rr>r.rr;
    }
};
priority_queue<xjy> qa;
priority_queue< xjyxjy > qi;
int main()
{
   int n=0;xjy mid;
   int step=1;int anstep=1;
   while(~scanf("%d",&n))
   {
   for(int i=0;i<n;i++)
        {
            scanf("%d%d",&mid.l,&mid.r);
            mid.num=i;
            a[i]=mid;
            qa.push(mid);
        }
    while(!qa.empty())
    {
        mid=qa.top();
        qa.pop();

        if(qi.empty()||qi.top().rr<mid.l)
        {
            if(qi.empty())
            {
                xjyxjy midmid;
                midmid.rr=mid.r;
                midmid.nnum=step;
                midmid.num=mid.num;
                step++;
                qi.push(midmid);
                ans[anstep].nnum=midmid.nnum;
                ans[anstep].num=midmid.num;
                anstep++;

            }
            else
            {
                xjyxjy midmid;
                midmid.rr=mid.r;
                midmid.nnum=qi.top().nnum;
                midmid.num=mid.num;
                qi.pop();
                qi.push(midmid);
                ans[anstep].nnum=midmid.nnum;
                ans[anstep].num=midmid.num;
                anstep++;
            }
        }
        else
        {
            xjyxjy midmid;
            midmid.rr=mid.r;
            midmid.nnum=step;
            midmid.num=mid.num;
            step++;
            qi.push(midmid);
            ans[anstep].nnum=midmid.nnum;
            ans[anstep].num=midmid.num;
            anstep++;
        }
    }
    step--;
    sort(ans+1,ans+anstep,cmp1);
    printf("%d\n",step);
    for(int i=1;i<anstep;i++)
        printf("%d\n",ans[i].nnum);
   }

}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值