HDU - 1285 确定比赛名次 &&UVA - 10305 Ordering Tasks (拓扑排序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1285点击打开链接

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27765    Accepted Submission(s): 11075


Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

Sample Input
  
  
4 3 1 2 2 3 4 3
 

Sample Output
  
  
1 2 4 3
 

Author
SmallBeer(CML)
 

Source
 

Recommend
lcy

感觉这道题题目有点说不清楚 他需要每次判断完之后就重新选择最小的数 同一个排名全部判断完才选择小的数


用一个邻接表记录每个数接下来的数就行 

然后判断那些入度为0的点

注意可能有重复边

#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int n=0;int m=0;
int outedge[555];
vector<int > adjtable[555];
vector<int > ::iterator it;
vector<int > ans;
int main()
{
    while(cin >> n >> m)
    {
        memset(outedge,0,sizeof(outedge));
        for(int i=0;i<=500;i++)
            adjtable[i].clear();
        ans.clear();
        for(int i=0;i<m;i++)
        {
            int x,y;
            cin >> x >> y;
            vector<int > ::iterator its;
            if((adjtable[x].end()==find(adjtable[x].begin(),adjtable[x].end(),y)))
            {
                outedge[y]++;
                adjtable[x].push_back(y);
            }
        }
        for(int i=1;i<=n;i++)
            sort(adjtable[i].begin(),adjtable[i].end());
        while(1)
        {
            
            int flag=1;
            for(int i=1;i<=n;i++)
                if(outedge[i]==0)
                    flag=0;
            if(!flag)
                
            {
                for(int i=1;i<=n;i++)
                {
                    if(outedge[i]==0)
                    {
                        ans.push_back(i);
                        for(it=adjtable[i].begin();it!=adjtable[i].end();it++)
                            outedge[(*it)]--;
                        outedge[i]--;
                        break;
                    }
                }
            }
            else
                break;
        }
        for(it=ans.begin();it!=ans.end()-1;it++)
            cout << (*it) << " ";
        cout << (*(ans.end()-1))<< endl;
    }
    
}


题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1246 点击打开链接

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task isonly possible if other tasks have already been executed.InputThe input will consist of several instances of the problem. Each instance begins with a line containingtwo integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is thenumber of direct precedence relations between tasks. After this, there will be m lines with two integersi and j, representing the fact that task i must be executed before task j.An instance with n = m = 0 will finish the input.OutputFor each instance, print a line with n integers representing the tasks in a possible order of execution.Sample Input5 41 22 31 31 50 0Sample Output1 4 2 5 3


最烦uva。。丑的半死。。

代码上面的就能过 而且不需要判断那些苛刻条件

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值