HDU - 4489 The King’s Ups and Downs (排列组合+dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4489点击打开链接

The King’s Ups and Downs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 684    Accepted Submission(s): 492


Problem Description
The king has guards of all different heights. Rather than line them up in increasing or decreasing height order, he wants to line them up so each guard is either shorter than the guards next to him or taller than the guards next to him (so the heights go up and down along the line). For example, seven guards of heights 160, 162, 164, 166, 168, 170 and 172 cm. could be arranged as:


or perhaps:


The king wants to know how many guards he needs so he can have a different up and down order at each changing of the guard for rest of his reign. To be able to do this, he needs to know for a given number of guards, n, how many different up and down orders there are:

For example, if there are four guards: 1, 2, 3,4 can be arrange as:

1324, 2143, 3142, 2314, 3412, 4231, 4132, 2413, 3241, 1423

For this problem, you will write a program that takes as input a positive integer n, the number of guards and returns the number of up and down orders for n guards of differing heights.
 

Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set consists of single line of input containing two integers. The first integer, D is the data set number. The second integer, n (1 <= n <= 20), is the number of guards of differing heights.
 

Output
For each data set there is one line of output. It contains the data set number (D) followed by a single space, followed by the number of up and down orders for the n guards.
 

Sample Input
  
  
4 1 1 2 3 3 4 4 20
 

Sample Output
  
  
1 1 2 4 3 10 4 740742376475050
 

解释起来有点复杂 

首先 这是一个像波一样的 我们将高的称做波峰 矮的称做波谷

当新增加的一人插在队伍两边的时候 a[i]+=a[i-1]

当新增的人插在中间的时候 我们就对其中的一段进行排列组合 

同时注意 选取的这两段的两端必须同为波峰或者波谷 而这种情况出现为当前这段总数的1/2

因此就可以知道 当前的a[i] 除了放在两边意外 还有内部所有排列组合可能出现的情况的递推 而这些就是计算新增加元素在内部的个数

注意排列组合其中一段为1时特判

#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
long long int jc(int x)
{
    long long int sum=1;
    for(int i=2;i<=x;i++)
        sum*=i;
    return sum;
}
long long int c(int x,int y)
{
    return jc(x)/jc(y)/jc(x-y);
}
int main()
{
    long long int a[60];
    memset(a,0,sizeof(a));
    a[1]=1;
    a[2]=2;
    a[3]=4;
    for(int i=4;i<=20;i++)
        {
            a[i]+=a[i-1];
            for(int j=1;j<i-1;j++)
            {
                if(j==1||i-1-j==1)
                    a[i]+=(a[j]*a[i-j-1]>>1)*c(i-1,j);
                else
                    a[i]+=(a[j]>>1)*(a[i-j-1]>>1)*c(i-1,j);
            }
        }
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int mid,m;
        scanf("%d%d",&m,&mid);
        printf("%d %lld\n",m,a[mid]);
    }

}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值