HDU - 1058 Humble Numbers (2 3 5 7丑数)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1058点击打开链接

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27993    Accepted Submission(s): 12344


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source

观察一下就可以发现当一个数是2357丑数时 他*2 3 5 7也是丑数

用最小堆进行筛选丑数 因为要去重因此不使用优先队列 用set

#include <bits/stdc++.h>
using namespace std;
#define maxn 2000000000
int num[6000];
int main()
{
	set<long long int >s;
	set<long long int >::iterator it;
	num[1]=1;
	s.insert(2);
	s.insert(3);
	s.insert(5);
	s.insert(7);
	int cnt=2;
	it=s.begin();
	while(cnt<=5842)
	{
		long long int mid=*it;
		//s.erase(it);
		//cout << mid <<endl;
		if(mid*2<=maxn)
			s.insert(mid*2);
		if(mid*3<=maxn)
			s.insert(mid*3);
		if(mid*5<=maxn)
			s.insert(mid*5);
		if(mid*7<=maxn)
			s.insert(mid*7);
		num[cnt++]=mid;
		it++;
	}
	long long int n;
	while(scanf("%lld",&n)!=EOF&&n!=0)
    {
           if( n%10==1&&n%100!=11)
            printf("The %lldst humble number is %lld.\n",n,num[n]);
        else if( n%10==2&&n%100!=12)
            printf("The %lldnd humble number is %lld.\n",n,num[n]);
        else if( n %10==3&&n%100!=13)
            printf("The %lldrd humble number is %lld.\n",n,num[n]);
        else
            printf("The %lldth humble number is %lld.\n",n,num[n]);

    }
}









  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值