Hdu 1671 Phone List 字典树+变形

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15867    Accepted Submission(s): 5336


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
 
  思路:简单题目,字典树应用+变形,主要是要注意一点,合法的号码是没有前缀也不是其他号码的前缀,也就是既要判断是不是他人的前缀,又要判断他人是不是自己的前缀,加两个标志就行了。
  AC代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

struct Node{

    Node *next[15];
    bool fsign;
    bool nsign;
    Node(){
        memset(next,NULL,sizeof(next));
        fsign=nsign=false;
    }
}*root;

Node * getNode(){

    Node * tmp=new Node();
    return tmp;
}

void Insert(char *p){
    Node * tmp=root;
    while(*p){
        int id=*p-'0';
        if(tmp->next[id]==NULL){
            tmp->next[id]=getNode();
            tmp->fsign=true;
        }
        tmp=tmp->next[id];
        p++;
    }
    tmp->nsign=true;
}

bool Search(char *p){
    Node *tmp=root;
    while(*p){
        int id=*p-'0';
        if(tmp->nsign) return true;

        if(tmp->next[id]!=NULL){
            tmp=tmp->next[id];
            p++;
        }
        else return false;
    }
    if(tmp->fsign) return true;
    else return false;
}

void del(Node * root){

    for(int i=0;i<15;i++){
        if(root->next[i])
            del(root->next[i]);
    }
    delete(root);
}


int main(){

    int t,n;
    char tmp[15];
    bool ok;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        ok=false;
        root=getNode();
        while(n--){
            scanf("%s",tmp);
            if(Search(tmp)){
                ok=true;
            }
            if(ok) continue;
            Insert(tmp);
        }
        if(ok) printf("NO\n");
        else printf("YES\n");
        del(root);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值