个人积分第十一场

I

题面如下:

 The bomb is about to explode! Please defuse it as soon as possible!
There is a display showing a number from 1 to 4 on the bomb. Besides
this, there are 4 buttons under the display. Each button is labeled  by a number from 1 to 4. The numbers on the buttons are always distinct.
There are 5 defusing stages in total. Pressing the correct button 
can progress the bomb to the next defusing stage. The number on the 
display and the number on each button may be different in different
stages. The bomb will be defused only when all 5 defusing stages get
passed. Pressing the incorrect button will cause the bomb to explode
immediately. Be careful!
Here is the detailed bomb defusing manual. Button positions are 
ordered from left to right.
Stage 1:
    If the display is 1, press the button in the second position.
    If the display is 2, press the button in the second position.
    If the display is 3, press the button in the third position.
    If the display is 4, press the button in the fourth position.
Stage 2:
    If the display is 1, press the button labeled "4".
    If the display is 2, press the button in the same position as you pressed in stage 1.
    If the display is 3, press the button in the first position.
    If the display is 4, press the button in the same position as you pressed in stage 1.
Stage 3:
    If the display is 1, press the button with the same label you pressed in stage 2.
    If the display is 2, press the button with the same label you pressed in stage 1.
    If the display is 3, press the button in the third position.
    If the display is 4, press the button labeled "4".
Stage 4:
    If the display is 1, press the button in the same position as you pressed in stage 1.
    If the display is 2, press the button in the first position.
    If the display is 3, press the button in the same position as you pressed in stage 2.
    If the display is 4, press the button in the same position as you pressed in stage 2.
Stage 5:
    If the display is 1, press the button with the same label you pressed in stage 1.
    If the display is 2, press the button with the same label you pressed in stage 2.
    If the display is 3, press the button with the same label you pressed in stage 4.
    If the display is 4, press the button with the same label you pressed in stage 3.
Input:
There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:
There are 5 lines. Each line contains 5 integers D, B1, B2, B3, B4 indicating the number on the display and the numbers on the buttons respectively. The i-th line correspond to the i-th stage.
Output:
For each test case, output 5 lines. The i-th line contains two integers indicating the position and the label of the correct button for the i-th stage.
Sample Input
1
4 2 1 3 4
2 2 4 3 1
4 3 1 4 2
4 3 4 2 1
2 3 1 2 4
Sample Output
4 4
4 1
3 4
4 1
2 1
Hint
Keep talking with your teammates and nobody explodes! 

本题思路极其清晰,运用结构体存按钮位置和按钮的数字,跟着题目模拟就行,但写的时候要注意细节不然找错找哭。代码实现:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define hhh 1005
int a[hhh][hhh];
int t;
struct Node{
int wz;
int an;
}v[hhh];
int kk(int x,int y){
    for(int i=1;i<5;i++){
        if(a[x][i]==y){
        	return i;
		}
    }
}
int main(){
    scanf("%d",&t);
    while(t--){
        for(int i=0;i<5;i++){
            for(int j=0;j<5;j++){
              scanf("%d",&a[i][j]);
            }
        }
        for(int i=0;i<5;i++){//五个阶段 
//阶段一 
            if(i==0&&a[i][0]==1){//如果显示为1,则在第二个位置按下按钮
                v[i].wz=2;
                v[i].an=a[i][2];
            }
			else if(i==0&&a[i][0]==2){//如果显示为2,则在第二个位置按下按钮
                v[i].wz=2;
                v[i].an=a[i][2];
            }
			else if(i==0&&a[i][0]==3){//如果显示为3,则在第三个位置按下按钮
                v[i].wz=3;
                v[i].an=a[i][3];
            }
			else if(i==0&&a[i][0]==4){//如果显示为4,则在第四个位置按下按钮
                v[i].wz=4;
                v[i].an=a[i][4];
            }
//阶段二 
			else if(i==1&&a[i][0]==1){//如果显示为1,按下标有4的按钮
                v[i].wz=kk(1,4);
                v[i].an=4;
            }
			else if(i==1&&a[i][0]==2){//如果显示为2,则在与在第1阶段中按下的位置相同的位置按下按钮 
                v[i].wz=v[0].wz;
                v[i].an=a[i][v[0].wz];
            }
			else if(i==1&&a[i][0]==3){//如果显示为3,则在第一个位置按下按钮
                v[i].wz=1;
                v[i].an=a[i][1];
            }
			else if(i==1&&a[i][0]==4){//如果显示为4,则在与在第1阶段中按下的位置相同的位置按下按钮
                v[i].wz=v[0].wz;
                v[i].an=a[i][v[0].wz];
            }
//阶段三 
			else if(i==2&&a[i][0]==1){//如果显示为1,则按与第2阶段中按的标签相同的按钮
                v[i].wz=kk(2,v[1].an);
                v[i].an=v[1].an;
            }
			else if(i==2&&a[i][0]==2){//如果显示为2,请按与第一阶段中按下的标签相同的按钮
                v[i].wz=kk(2,v[0].an);
                v[i].an=v[0].an;
            }
			else if(i==2&&a[i][0]==3){//如果显示为3,则在第三个位置按下按钮
                v[i].wz=3;
                v[i].an=a[i][3];
            }
			else if(i==2&&a[i][0]==4){//如果显示为4,按下标有4的按钮
                v[i].wz=kk(2,4);
                v[i].an=4;
            }
//阶段四 
			else if(i==3&&a[i][0]==1){//如果显示为1,则在与在第1阶段中按下的位置相同的位置按下按钮
                v[i].wz=v[0].wz;
                v[i].an=a[i][v[0].wz];
            }
			else if(i==3&&a[i][0]==2){//如果显示为2,按第一个位置的按钮
                v[i].wz=1;
                v[i].an=a[i][1];
            }
			else if(i==3&&a[i][0]==3){//如果显示为3,则在第2阶段按下的位置按下按钮
                v[i].wz=v[1].wz;
                v[i].an=a[i][v[1].wz];
            }
			else if(i==3&&a[i][0]==4){//如果显示为4,则在第2阶段按下的位置按下按钮
                v[i].wz=v[1].wz;
                v[i].an=a[i][v[1].wz];
            }
//阶段五 
			else if(i==4&&a[i][0]==1){//如果显示为1,请按与第1阶段中按的标签相同的按钮
                v[i].wz=kk(i,v[0].an);
                v[i].an=v[0].an;
            }
			else if(i==4&&a[i][0]==2){//如果显示为2,请按与第2阶段中按的标签相同的按钮
                v[i].wz=kk(i,v[1].an);
                v[i].an=v[1].an;
            }
			else if(i==4&&a[i][0]==3){//如果显示为3,请按与第4阶段中按的标签相同的按钮
                v[i].wz=kk(i,v[3].an);
                v[i].an=v[3].an;
            }
			else if(i==4&&a[i][0]==4){//如果显示为4,请按与第3阶段中按的标签相同的按钮
                v[i].wz=kk(i,v[2].an);
                v[i].an=v[2].an;
            }
        }
        for(int i=0;i<5;i++){
        	printf("%d %d\n",v[i].wz,v[i].an);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值