【算法笔记第7.3节 】链表处理

这篇博客探讨了链表处理,包括动态链表和静态链表的概念。文章通过具体的问题实例——1032 Sharing 和 1052 Linked List Sorting,解释了如何在链表中查找共享后缀以及如何对链表进行排序。对于1032 Sharing,任务是找到两个单词共享的后缀起始位置;在1052 Linked List Sorting中,要求按升序排序链表中的节点。
摘要由CSDN通过智能技术生成

一. 动态链表

#include<stdio.h>
#include<stdlib.h>
struct node{
   int data; //数据域
   node* next;//指针域
};
/*
malloc函数是c语言中stdlib.h头文件下用于申请动态内存的函数,其返回类型为申请的同变量类型的指针。
*/

node* create(int a[])
{
    /*
    head: 头结点
    temp: 临时结点
    now:链表的当前尾结点
    */
    node *now, *temp, *head;
    head = new node;
    head->next = NULL;//数据域为空
    now = head;
    for(int i=0; i<5; i++)
    {
        temp = new node;//临时结点
        temp->data = a[i];
        temp->next = NULL;
        now->next = temp;
        now = temp;
    }

    return head;
}

/*
返回的为链表中x的个数
*/
int search(node* head, int x)
{
    int cnt = 0;
    node* temp = head->next;
    while(temp!=NULL)
    {
        if(temp->data==x)
            cnt++;
        temp = temp->next;
    }
    return cnt;
}

//将x插入以head为头结点的链表的第pos个位置上
void insert(node* &head, int pos, int x)
{
    node *temp = head;
    for(int i=0; i<pos-1; i++)
        temp = temp->next;
    node* newnode = new node;
    newnode->data = x;
    newnode->next = temp->next;
    temp->next = newnode;
}

/*
删除元素:删除链表上所有为给定的数x。
1. 由指针now枚举结点,pre表示now指向结点的前驱结点
2. 当now所指结点的数据域恰好为x时,
   令pre所指结点的指针域next指向now所指结点的下一个结点
   释放now所指结点的内存空间
   令now指向pre所指结点的下一个结点。

*/
void del(node* &head, int x)
{
    node *now = head->next;//从第一个结点开始枚举
    node *pre = head;
    while(now!=NULL)
    {
        if(now->data==x)
        {
            pre->next = now->next;
            delete(now);
            now = pre->next;
        }
        else
        {
            pre =  now;
            now  = now -> next;
        }
    }
}
int main()
{
    int a[10] = {5, 3, 6, 1, 2};
    node *head = create(a), *L;//新建链表,返回头指针head赋给L
    insert(head,2, 10);
    del(head,6);
    L = head->next;//从第一个结点开始有数据域
    while(L!=NULL)
    {
        printf("%d ",L->data);//输出每一个数据域
        L = L->next;
    }
    printf("\n");
    printf("%d\n",search(head, 5));
    return 0;
}

二. 静态链表

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1
#include<stdio.h>
#include<stdlib.h>
const int maxn = 100010;
struct Node
{
    int data;
    int next;
    bool flag; //结点是否在第一条链表中出现
}node[maxn];
int main()
{
    for(int i=0; i<maxn; i++)
        node[i].flag = false;
    int s1, s2, n;
    scanf("%d%d%d",&s1, &s2, &n);
    int address, next;
    char data;
    for(int i=0; i<n; i++)
    {
        scanf("%d %c %d",&address, &data, &next);
        node[address].data = data;
        node[address].next = next;
    }
    int index;
    for(index = s1; index!=-1; index = node[index].next)
        node[index].flag = true;
    for(index = s2; index!=-1; index = node[index].next)
    {
        //找到第一个已经在第一条链表中出现的结点
        if(node[index].flag==true) break;
    }
    if(index!=-1)
        printf("%05d\n",index);
    else
        printf("-1\n");
    return 0;
}

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int maxn = 100010;
struct Node     //步骤1
{
    int address;
    int data;
    int next;
    bool flag; //结点是否在第一条链表中出现
}node[maxn];
bool cmp(Node a, Node b)
{
    if(a.flag==false||b.flag==false)
        return a.flag > b.flag;//无效的放后面
    else
        return a.data < b.data;
}
int main()
{
    for(int i=0; i<maxn; i++)   //初始化 步骤2
        node[i].flag = false;

    int n, begin ,address;
    scanf("%d%d",&n, &begin);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&address);
        scanf("%d%d",&node[address].data, &node[address].next);
        node[address].address = address;
    }

    //枚举链表,对flag进行标记,同时计数有效结点个数 步骤3
    int cnt = 0, temp = begin;
    while(temp!=-1)
    {
        node[temp].flag = true;
        cnt++;
        temp = node[temp].next;
    }
    if(cnt==0)
        printf("0 -1");
    else
    {
        //筛选有效结点,并按data从小到大排序(步骤4)
        sort(node, node+maxn, cmp);

       //防止-1被%05化,提前判断
       printf("%d %05d\n", cnt, node[0].address);
       for(int i=0; i<cnt; i++)
       {
           if(i!=cnt-1)
               printf("%05d %d %05d\n", node[i].address, node[i].data, node[i+1].address);
           else
               printf("%05d %d -1\n", node[i].address, node[i].data);

       }

    }

    return 0;
}

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值