【算法笔记第9.2节-树 】问题 D: 二叉树遍历(先序字符串建树)

题目描述

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

输入

 

输入包括1行字符串,长度不超过100。

 

输出

 

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

 

样例输入

a#b#cdef#####
a##

样例输出

a b f e d c 
a 
#include<stdio.h>
#include<string.h>
typedef long long int LL;
char a[101];
struct node
{
    char data;
    node *lchild;
    node *rchild;
};

node* creat(int &index)//这里Index要引用
{
    if(a[index]=='#')
        return NULL;
    node *root = new node;
    root->data = a[index];
    index++;
    root->lchild = creat(index);
    index++;
    root->rchild = creat(index);
    return root;
}
void in(node *root)
{
    if(root==NULL)
        return;
    in(root->lchild);
    printf("%c ",root->data);
    in(root->rchild);
}
int main()
{
    while(scanf("%s",a)!=EOF)//输入先序字符串
    {
        int index = 0;
        node *root = creat(index);
        in(root);
        printf("\n");
    }

   return 0;

}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值