poj3268Silver Cow Party之dijkstra解法

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23651 Accepted: 10789
Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output

10


  • 题意
    一群牛1….n要去x家开party,每头牛都希望选择路径使得来回路程尽可能小,求这些最短路程中的最大值.

  • 分析
    把路径反向,得到另一个图.两次dijkstra后,求所有和中的最大值.


#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
using namespace std;

#define INF 1 << 30
typedef pair<int,int> P;//first存放距离,sescond存放节点
int n,m,x;
int a,b,t;
int d1[1001],d2[1001];

struct edge{
    int to,cost;
    edge (){}
    edge (int to,int cost):to(to),cost(cost){};
};
vector<edge> G1[1001],G2[1001];

void dijkstra(int xx,int d[1001],vector<edge> G[1001])
{
    priority_queue<P,vector<P>,greater<P>> que;//按照路径长度由小到大排序
    fill(d+1,d+n+1,INF);
    d[x] = 0;
    que.push(P(0,x));

    while (!que.empty()){
        P p = que.top(); que.pop();//取当前最短路径
        int s = p.second;
        for (unsigned int i = 0; i < G[s].size(); i += 1){
            edge e = G[s][i];
            if (d[e.to] > d[s]+e.cost){
                d[e.to] = d[s]+e.cost;
                que.push(P(d[e.to],e.to));
            }
        }
    }
}

int main()
{
    int ans = 0;
    cin >> n >> m >> x;
    for (int i = 0; i < m; i += 1){
        cin >> a >> b >> t;
        G1[a].push_back(edge(b,t));
        G2[b].push_back(edge(a,t));
    }
    dijkstra(x,d1,G1);
    dijkstra(x,d2,G2);
    for (int i = 1; i <= n; i += 1){
        ans = max(ans,d1[i]+d2[i]);
    }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值