贪心算法之区间取点问题

贪心算法之区间取点问题

题目描述:

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

解题思路:

此题意思给定点集S={(xi,yi)i=1.2.3...n},求用圆心在x轴上,半径为d的圆覆盖S所需的圆的最少个数。

1.先把给出的岛的坐标(xi.yi)和半径r转化为在x轴上的区间,即当d-yi>=0时,圆心位于x轴上的区间为Ii=[ xi-sqrt(d^2-yi^2) , xi + sqrt( d^2 - yi^2 )],则转化为区间选点问题。

2.S中点(xi,yi),对应一个在x轴上的区间Ii=(li,ri),按照区间右端点ri从小到大排序,在区间集合中选择一个索引最小的区间,把选择的区间和与其相交的所有区间作为一组从T中删除,直到T为空集、

3则剩下的分组的组数即为m的最小值。。。

AC代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#define MAX 1010

using namespace std;

class Range
{
public:
float left;
float right;
bool operator<(const Range &r)const
{
if(right<r.right||(right==r.right&&left>r.left))
return true;
else
return false;
}
};

int main(int argc,char *argv[])
{
int n,d;
int x,y;
int i,j;
int count=1,ans;
while(scanf("%d%d",&n,&d)&&(n+d))
{
Range r[MAX];
j=0;
ans=0;
for(i=0;i<n;i++)
{
Range temp;
scanf("%d%d",&x,&y);
if(d>=y)
{
temp.left=x-sqrt(d*d-y*y);
temp.right=x+sqrt(d*d-y*y);
    r[j++]=temp;
}
}
sort(r,r+j);
if(j<n)
printf("Case %d: -1\n",count);
else
{
float end=-0x0FFFFFFF;
for(i=0;i<j;i++)
{
if(end<r[i].left)
{
ans++;
end=r[i].right;
}
}
printf("Case %d: %d\n",count,ans);
}
count++;
}
return 0;
}


解题方法跟求最大区间数极其相似。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xxpr_ybgg

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值