7-2 两个有序链表序列的交集 (20分)

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。

输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:

在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL

输入样例:

1 2 5 -1
2 4 5 8 10 -1

输出样例:

2 5

 

#include<bits/stdc++.h>
using namespace std;
typedef struct lnode
{
    int data;
    lnode *next;
} lnode;

int main()
{
    lnode *head1 = (lnode*)malloc(sizeof(lnode)),*r1 = head1;
    lnode *head2 = (lnode*)malloc(sizeof(lnode)),*r2 = head2;
    lnode *head3 = (lnode*)malloc(sizeof(lnode)),*r3 = head3;
    int num;
    while(cin>>num && num!=-1)
    {
        lnode *p = (lnode*)malloc(sizeof(lnode));
        p->data = num;
        p->next = NULL;

        r1->next = p;
        r1 = p;
    }
    while(cin>>num && num!=-1)
    {
        lnode *p = (lnode*)malloc(sizeof(lnode));
        p->data = num;
        p->next = NULL;

        r2->next = p;
        r2 = p;
    }

    lnode *s;
    head1 = head1->next;
    head2 = head2->next;
    while(head1 && head2)
    {
        if(head1->data == head2->data)
        {
            s = head1;
            head1 = head1->next;
            head2 = head2->next;
            s->next = NULL;

            r3->next = s;
            r3 = s;
        }
        else if(head1->data < head2->data) head1 = head1->next;
        else head2 = head2->next;
    }

    if(head3->next == NULL) {cout<<"NULL";return 0;}
    int flag=1;
    head3 = head3->next;
    while(head3)
    {
        if(flag==1)
        {
           cout<<head3->data;
           flag =0;
        }
        else cout<<' '<<head3->data;
        head3 = head3->next;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值