hdu1237(经典的栈的题目)

99 篇文章 2 订阅

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19708    Accepted Submission(s): 6952


Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
 

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
 

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
 

Sample Input
 
 
1 + 2 4 + 2 * 5 - 7 / 11 0
 

Sample Output
 
 
3.00 13.36
 

Source

写完这道题可以自己做个计算器了hhhh   数字先入栈,+号就把数字入栈,-号就把把数字加个负号入栈,如果是乘号就取出栈顶元素乘上去,除号同理,最后计算栈中所有数字的和就是答案了。
STL大法 好~
#include <stdio.h>
#include <stack>
#include <algorithm>
using namespace std;
int main()
{
	double n,m;
	char c;
	while(~scanf("%lf",&n))
	{
		c=getchar();
		if(c=='\n' &&n==0)
			break;
		stack<double>s;
		s.push(n);
		scanf("%c",&c);
		while(~scanf("%lf",&n))
		{ 
			if(c=='*')
			{
				m=s.top();
				m*=n;
				s.pop();
				s.push(m);
			}
			if(c=='/')
			{
				m=s.top();
				m/=n;
				s.pop();
				s.push(m);
			}
			if(c=='+')
				s.push(n);
			if(c=='-')
				s.push(0-n);
			if(getchar()=='\n')
				break;
			c=getchar();
		}
		double sum=0;
		while(!s.empty())
		{
			sum+=s.top();
			s.pop();
		}
		printf("%.2lf\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值