poj_2234

做AdHoc的題目放了一道博弈論,當時一看就知道是Nim遊戲。之前聽老師說過,也遇到過類似的題目,只是都沒有去看和寫過。

遊戲的大致規則就是給兩個玩家在n堆石子中輪流拿走石子,每個玩家每次只能從一堆中至少拿一個(當然不能超過那堆的個數),

輪到玩家沒石子可拿那個玩家就輸(就是拿走最後剩餘石子的玩家贏)。

問,先拿石子的玩家在兩個玩家都是最優策略的情況下能否贏。

做法,設每堆石子的個數分別為a1,a2,a3,a4.....an-1,an。

設ans=a1 XOR a2 XOR a3 XOR a4 ...XOR an-1 XOR an,若ans=1,則先拿的人必贏,否則先拿的必輸

這是Nim遊戲最基本的情況,還有不少引申和變型,比如Sprague-Grundy function今天就沒全懂,特別是G值得算法

下面是題目:

 

Matches Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8446 Accepted: 4880

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

Source

POJ Monthly,readchild

 

下面是AC代碼:

#include<cstdio>
#include<cstdlib>
#include<cstring>
int main()
{
   int n,i,j;
   freopen("in.txt","r",stdin);
   freopen("out.txt","w",stdout);

   while(scanf("%d",&n)==1)
   {
      int ans=0;
      for(i=0;i<n;i++)
         {
            int u;
            scanf("%d",&u);
            ans^=u;
         }
         if(ans) printf("Yes\n");
            else printf("No\n");
   }
   return 0;
} 


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值