poj 2299 归并排序--逆序对

Ultra-QuickSort
Time Limit: 7000MS
Memory Limit: 65536K
Total Submissions: 21264
Accepted: 7578

DescriptionIn this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5 9 1 0 5 4 3 1 2 3 0 

Sample Output

6 0
题意是让你求将一组数排序的最小交换次数,其实就是求逆序对。。。注意应该用64位
下面是我的代码
#include<cstdio>
#include<iostream>
#define N 500005 
__int64 a[N],t[N],cnt; 
using namespace std; 
void merge(int x,int y,long long *a,long long *t) 
{ 
	int m,i,sum=0,p,q; 
	if(y-x>1) { m=x+(y-x)/2;
	p=x,q=m,i=x;
	merge(x,m,a,t);
	merge(m,y,a,t); 
	while(p<m||q<y) 
	{ 
		if(q>=y||(p<m&&a[p]<a[q])) 
		{ t[i++]=a[p++]; } 
		else { t[i++]=a[q++]; cnt+=m-p; }
	}  
	for(i=x;i<y;i++) 
		a[i]=t[i]; 
	}  
} 
int main() 
{ 
	int i,n; while(1) 
	{ cin>>n; if(n==0) 
	return 0;
	for(i=0;i<n;i++) 
	{ cin>>a[i]; } 
	cnt=0; 
	merge(0,n,a,t);
	printf("%I64d\n",cnt); 
	} 
	return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值