求数组最大的和

 

 

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int a[100015];
int dp[100015];
int main()
{
	int n;
	int thisstart,thisend;
	int maxstart,maxend;
	int thissum,maxsum;
	cin>>n;
	int p=n;
	int count=0;
	while(n--)
	
	{   
	    int m;
	    cin>>m;
		for(int i=0;i<m;i++)
	     {
	     	cin>>a[i];
		 }
		 dp[0]=a[0];
		 thissum=dp[0];
		 maxsum=dp[0];
		 thisstart=0;
		 thisend=0;
		 maxstart=0;
		 maxend=0;
		 for(int i=1;i<m;i++)
		 {
		 	if(dp[i-1]<0)
		 	{
			 dp[i]=a[i];
		 	thisstart=i;
		 	thisend=i;
			 }
		 
		 	else{	
			 dp[i]=dp[i-1]+a[i];
			 thissum=dp[i];
			 if(thissum>maxsum){
			 
			    maxsum=thissum;
			    maxend=i;
			    maxstart=thisstart;
			  }  
			 }
		 			 	
		 }
		 if(maxsum<0)
		  {
		  	maxstart=0;		  	 
		  	 maxsum=a[0];
		  	 for(int i=1;i<m;i++)
		  	 {
		  	 	if(a[i]>maxsum)
		  	 	{
		  	 		maxsum=a[i];
		  	 		maxstart=i;
		  	 		
				   }
				}
				maxend=maxstart; 
		  }
		 count++;
		 cout<<"Case "<<count<<":"<<endl;		 
		 cout<<maxsum<<" "<<maxstart+1<<" "<<maxend+1<<endl;
		 if(count!=p)
		 cout<<endl;    
}
	return 0;
 } 
/* HDU 1003 Max Sum --- 经典DP */
#include <cstdio>
#include <cstring>

int dp[100005];

int main()
{
    int t, n;
    int kase = 0;
    int fst, lst, maxSum; //记录首位位置以及最大和
    int start; //start是用于记录中间变化的起点的
    scanf("%d", &t);
    while (t--){
        scanf("%d", &n);
        for (int i = 0; i < n; ++i){
            scanf("%d", dp + i);
        }//for(i)

        start = fst = lst = 0;
        maxSum = dp[0];
        for (int i = 1; i < n; ++i){
            //dp[i] = MAX(dp[i - 1] + dp[i], dp[i]);
            //由于是从前往后更新的,可以省下一个dp数组
            if (dp[i-1] >= 0){
                dp[i] = dp[i - 1] + dp[i];
            }
            else{
                start = i; //抛弃dp[i-1],则起点发生变化
            }

            if (dp[i] > maxSum){
                //若当前求得的子序列和最大,进行更新
                maxSum = dp[i];
                fst = start;
                lst = i;
            }
        }
        if (kase){
            printf("\n");
        }
        printf("Case %d:\n", ++kase);
        printf("%d %d %d\n", maxSum, fst+1, lst+1);
    }

    return 0;
}

以上这个是比较简单的方法

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值