Couple doubi
Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
Input
Multiply Test Cases. In the first line there are two Integers k and p(1<k,p<2^31).
Output
For each line, output an integer, as described above.
Sample Input
2 3 20 3
Sample Output
YES NO
题意:
给你k个球,每个球的价值是1^i+2^i+...+(p-1)^i (mod p),两个人分别每次拿一个球,最后谁的价值高,谁就赢,求最后第一个人是否会赢,如果赢了,就输出YES,反之,输出NO。
由题意可知,可以肯定两人每次都是拿价值最高的那个。
1^i+2^i+...+(p-1)^i (mod p)除了是p-1的倍数的时候,不为零,其他情况都为零。
代码:
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int k,p;
while(~scanf("%d%d",&k,&p))
{
k=k/(p-1);
if(k%2==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}