k8s版本升级脚本(一键升级k8s版本脚本)

hi!~今天对咱们的k8s脚本修复完毕,修改了不少函数。
另外写了一个k8s升级脚本,只要是用波哥的k8s一键部署脚本部署的集群,您可以升级到任意版本啦!如是最好,这样我就不用每个版本都写一个部署脚本了。
那么能升到哪些版本呢?
在这里插入图片描述
凡是用

yum list --showduplicates kubeadm --disableexcludes=kubernetes

能查到的版本都可以一键升级包括(1.17.0),当然前提是你老版本的k8s集群是用我写的一键部署脚本部署的。

波哥直接将1.14.1升级至1.15.7(最稳定版本)
在这里插入图片描述
那么如何升级呢?波哥的老朋友应该都摸清波哥的套路了。是的,我们只需要修改一下参数,然后执行脚本。

image

就这些参数,这里的参数需要跟老集群的一样,包括IP,主机名:
除了kubeadm_version=“1.14.10”,这个是你要升级的目标版本号。比如波哥之前有个1.14.1版本,你想升级到1.14.10也就是这个版本的最稳定版本。那么你就写1.14.10。
版本号大家要看好哦!就写红圈里面的,不要带后边的-0

image

然后执行

image
即可升级!
升级规则是一个node一个node升级,正在升级的node会被禁止调用,并且驱赶上面的pods。升级完毕会解除禁止调用。pods会被漂移回来!
有了这个脚本,大家就不用重新部署啦!
觉得有帮助,别忘了帮波哥转发哦!~
关注公众号回复:** 升级脚本 **即可获得该脚本

在这里插入图片描述

发布了50 篇原创文章 · 获赞 0 · 访问量 1600
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览