POJ 1681 Painter's Problem

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob's brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow. 

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a 'w' to express a white brick while a 'y' to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can't paint all the bricks yellow, print 'inf'.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15

枚举。先给出第一行,后面各行都根据上一行涂色,这样后面各行固定,只需枚举第一行状态就行了。

#include<iostream>
#include<string>
using namespace std;
int wall[16][16];//黄色为1,白色为0 
int paintcount;//涂画砖的块数 
int mincount;//最小砖块涂画数 
bool hasway = false;//是否有方法可以全部涂成黄色 
//判断是不是可以完全涂成黄色 
bool isWay(int paint[16][16], int n){
	int i, j;
	for(i = 1; i < n; i ++){
		for(j = 0; j < n; j ++){
			if(((paint[i - 1][j] + wall[i - 1][j]) % 2) == 0){
				paintcount ++;
				paint[i][j] = (paint[i][j] + 1) % 2;
				paint[i - 1][j] = (paint[i - 1][j] + 1) % 2;
				if(j >= 1) paint[i][j - 1] = (paint[i][j - 1] + 1) % 2;
				if(j < n - 1) paint[i][j + 1] = (paint[i][j + 1] + 1) % 2;
				if(i < n - 1) paint[i + 1][j] = (paint[i + 1][j] + 1) % 2;
			} 
		}
	}
	for(j = 0; j < n; j ++){
		if((paint[n - 1][j] + wall[n - 1][j]) % 2 == 0){
			return false;
		} 
	}
	return true;
}
int emucount(int line[16], int n){
	int i;
	int count = 0;
	for(i = 0; i < n; i ++){
		if(line[i]) count ++;
	}
	return count;
}
//模拟二进制数对首行进行枚举 
void enumerate(int n){
	
	int paint[16][16];
	int line[16];
	int count = 0;
	int i, j;
	paintcount = 0; 
	mincount = 999999;
	for(i = 0; i < n; i ++){
		line[i] = 0;
		for(j = 0; j < n; j ++)
			paint[i][j] = 0;
	}
    
	if(isWay(paint, n)){
			hasway = true;
			if(paintcount < mincount) mincount = paintcount;
	} 
	while(emucount(line, n) < n){
		
		line[0] ++;
		for(i = 0; i < n; i ++){
			if(line[i] == 2){
				line[i + 1] ++;
				line[i] = 0;
			}
		}
		for(i = 0; i < n; i ++){
		   for(j = 0; j < n; j ++){
	           paint[i][j] = 0;
	    	}		  
	    }
	    for(j = 0; j < n; j ++){
		if(line[j] == 1){
			  paint[0][j] = (paint[0][j] + 1) % 2;
		      if(j >= 1) paint[0][j - 1] = (paint[0][j - 1] + 1) % 2;
		      if(j < n - 1) paint[0][j + 1] = (paint[0][j + 1] + 1) % 2;
		      if(n > 1) paint[1][j] = (paint[1][j] + 1) % 2;
			} 
	    }
		paintcount = emucount(line, n);
		if(isWay(paint, n)){
			hasway = true;
			if(paintcount < mincount) mincount = paintcount;
		} 
	}
} 
int main(){
	int t;
	int n;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		int i, j;
		for(i = 0; i < n; i ++){
			char s[16];
			scanf("%s", s);
			for(j = 0; j < n; j ++){
			    if(s[j] == 'y') wall[i][j] = 1;
			    else wall[i][j] = 0;
			}	
		}
		hasway = false;
		enumerate(n);
		if(hasway) printf("%d\n", mincount);
	    else printf("inf\n");
	}
return 0;	
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值