POJ 2663 Tri Tiling

Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 
Here is a sample tiling of a 3x12 rectangle. 

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1

Sample Output

3
153
2131

关键是找出递推公式。

当n为偶数时:

f(n) = 3 * f(n - 2) + 2 * f(n - 4) + 2 * f(n - 6) + .... + 2 * f(0)

f(0) = 1

当n为奇数时:

f(n) = 0

#include<stdio.h>
#include<string.h>
int a[30];
int func(int n){
	int i, sum = 0;
	if(n == 0) return 1;
	if(a[n] != 0) return a[n];
	for(i = n - 2; i >= 0; i -= 2){
		if(i == n - 2) sum += 3 * func(i);
		else sum += 2 * func(i);
	}
	a[n] = sum;
	return sum;
}
int main(){
	int n;
    memset(a, 0, sizeof(a));
    while(1){
   		scanf("%d", &n);
   		if(n == -1) return 0;
   		if(n % 2) printf("0\n");
    	else printf("%d\n", func(n));
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值