POJ 2533 Longest Ordered Subsequence

题目

总时间限制: 2000ms 内存限制: 65536kB
描述
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
输入
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
输出
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
样例输入
7
1 7 3 5 9 4 8
样例输出
4
来源
Northeastern Europe 2002, Far-Eastern Subregion

思路

动态规划。 maxlen(k) 表示以 ak 为终点的最长上升子序列长度.

maxlen(1)=1maxlen(k)=Max{maxlen(i):1<i<k and ai<ak and k1}+1

代码

while True:
    try:
        N = int(input().strip())
        nums = input().strip().split()
        nums = [int(i) for i in nums]
        dp = []
        dp.append(1)
        for i in range(1, N):
            maxnum = 0
            for j in range(0, i):
                if nums[i] > nums[j] and maxnum < dp[j]:
                    maxnum = dp[j]
            dp.append(maxnum + 1)
        print(max(dp))
    except:
        break
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值