B - Girls and Boys(二分匹配 最大独立集)

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

Output

5

2

Sample Input

7

0: (3) 4 5 6

1: (2) 4 6

2: (0)

3: (0)

4: (2) 0 1

5: (1) 0

6: (2) 0 1

3

0: (2) 1 2

1: (1) 0

2: (1) 0

Sample Output

5

2

  • 题意概括  :

浪漫关系的研究,输入n,然后是n行数字,每行第一个数字为学生编号,第二个数字为匹配学生的总数k,然后是k个学生的编号,问最小的没有匹配的学生数为多少。

  • 解题思路  :

求最大独立集,最大独立集 = 顶点数 - 最大匹配数(最小顶点覆盖数),因为本题没有给出具体的性别,所以会造成重复现象,求出最大匹配数除以二才是实际的最大匹配数。

#include<stdio.h>
#include<string.h>

int map[1010][1010],book[1010],girl[1010];
int n,m;

int dfs(int u)
{
	int i;
	
	for(i = 0;i<n;i ++)
	{
		if(book[i] == 0&&map[u][i] == 1)
		{
			book[i] = 1;
			if(girl[i] == 0||dfs(girl[i]))
			{
				girl[i] = u;
				return 1;
			}
		}
	}
	return 0;
}

int main()
{
	int i,j,sum,t1,t2;
	char ch,th,sh;
	
	while(~ scanf("%d",&n))
	{
		memset(girl,0,sizeof(girl));
		memset(map,0,sizeof(map));
		sum = 0;
		
		for(i = 0;i<n;i ++)
		{
			scanf("%d: (%d)",&t1,&m);
			for(j = 0;j<m;j ++)
			{
				scanf("%d",&t2);
				map[t1][t2] = 1;
			}
		}
		
		for(i = 0;i<n;i ++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
			sum ++;
		}
		printf("%d\n",n-sum/2);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值