根据先序遍历和中序遍历重建二叉树的两种方法

Problem Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!


Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.


Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input
  
  
DBACEGF ABCDEFG BCAD CBAD


Sample Output
   
   
ACBFGED CDAB
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct tree//定义树结构
{
    char data;
    struct tree *left,*right;
};

struct tree *build(int n,char *s1,char *s2)//重建一个含n个结点的树。并返回根结点的指针
{
    if(n<=0)
        return NULL;
    int p=strchr(s2,s1[0])-s2;//后序遍历中找到根的位置。
    //开始写成减s2了导致异常终止.
    struct tree*root=(struct tree*)malloc(sizeof(struct tree));

    root->left=build(p,s1+1,s2);//建左树
    root->right=build(n-p-1,s1+p+1,s2+p+1);//建右树
    root->data=s1[0];
    return root;
}
void  out(struct tree*root)//后序遍历
{
    if(root==NULL)//写成=号了。超级低级错误!
        return;
    out(root->left);
    out(root->right);
    printf("%c",root->data);
}
int main()
{
    char s1[80],s2[80];
    struct tree *root;
    int len;

    while(scanf("%s%s",s1,s2)!=EOF)
    {
        len=strlen(s1);
        root=build(len,s1,s2);
        out(root);
        printf("\n");
    }
    return 0;
}

这种方法要求返回一个树结构指针。用来修改父节点左右儿子指针。建立二叉树。


#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct tree
{
    char data;
    struct tree *left,*right;
};

void build(int n,struct tree**pt,char *s1,char *s2)//重建一个含n个结点的树。并返回根结点的指针
{
    if(n<=0)
    {
        *pt=NULL;
        return ;
    }
    int p=strchr(s2,s1[0])-s2;//后序遍历中找到根的位置。
    //开始写成减s2了导致异常终止.
    struct tree*root=(struct tree*)malloc(sizeof(struct tree));

    build(p,&root->left,s1+1,s2);//建左树
    build(n-p-1,&root->right,s1+p+1,s2+p+1);//建右树
    root->data=s1[0];
    *pt=root;
}
void  out(struct tree*root)//后序遍历
{
    if(root==NULL)//写成=号了。超级低级错误!
        return;
    out(root->left);
    out(root->right);
    printf("%c",root->data);
}
int main()
{
    char s1[80],s2[80];
    struct tree *root;
    int len;

    while(scanf("%s%s",s1,s2)!=EOF)
    {
        len=strlen(s1);
        build(len,&root,s1,s2);
        out(root);
        printf("\n");
    }
    return 0;
}

第二种方法给建树函数传一个父亲指针的二级指针。用以修改父级指针,建立二叉树。

最后一种方法不用建树直接把后序遍历保存进数组
#include <stdio.h>
#include<string.h>

void build(int n,char *s1,char *s2,char *s)
{
    if(n<=0)
        return;
    int p=strchr(s2,s1[0])-s2;
    build(p,s1+1,s2,s);
    build(n-p-1,s1+p+1,s2+p+1,s+p);
    s[n-1]=s1[0];
}
int main()
{
    char s1[30],s2[30],s[30];
    int n;

    while(scanf("%s%s",s1,s2)==2)
    {
        n=strlen(s1);
        build(n,s1,s2,s);
        s[n]='\0';
        printf("%s\n",s);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值