hdu 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 154521 Accepted Submission(s): 29236


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

水题但是需要注意的细节有很多。
#include <stdio.h>
#include<string.h>
char a[1500],b[1500];
int c[1500],d[1500];

int change(char *s,int *value)
{
    int len,i,j,temp,flag=0;//用于去掉前导0,虽然这道题没用到

    for(i=0,j=0;s[i]!='\0';i++)
    {
        temp=s[i]-'0';
        if(temp!=0)
            flag=1;
        if(flag==1||s[i+1]=='\0')//将字符串转换为数字存入int数组。排除全0情况
            value[j++]=temp;
    }
    len=j-1;
    for(i=0,j=len;i<j;i++,j--)//将int数组倒置方便运算
    {
        temp=value[i];
        value[i]=value[j];
        value[j]=temp;
    }
    return len;
}
int main()
{
    int t,i,j,len,len1,len2,s;

    scanf("%d",&t);
    getchar();//注意用它接收回车字符
    for(i=1;i<=t;i++)
    {
        memset(c,0,sizeof c);
        memset(d,0,sizeof d);
        scanf("%s%s",a,b);
        len1=change(a,c);
        len2=change(b,d);
        len=len1>len2?len1:len2;
        s=j=0;
        while(1)
        {
            if(s==0&&c[j]==0&&d[j]==0&&j>len)//判断运算是否结束
                break;
            c[j]=c[j]+d[j]+s;//模拟手算
            s=c[j]/10;
            c[j]=c[j]%10;
            j++;
        }
        len=j-1;
        printf("Case %d:\n",i);
        printf("%s + %s = ",a,b);//注意格式
        for(j=len;j>=0;j--)
            printf("%d",c[j]);
        printf("\n");
        if(i<t)//注意最后一组数据后没空格!!!
            printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值