zoj 3714 Java Beans

Java Beans

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ MN). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input
2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75
Sample Output
16
158

Author: FAN, Yuzhe

Contest: The 10th Zhejiang Provincial Collegiate Programming Contest

题目大意是n个小朋友做一圈。每个小朋友手中有ci个豆子。现在要找出m个连续的小朋友使得他们的豆子和最大。


#include <stdio.h>

int bean[250];//存豆子
int main()
{
    int t,m,n,i,msum,sum;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        bean[0]=0;
        sum=msum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&bean[i]);
            bean[i]+=bean[i-1];//这样求减少求和次数
        }
        for(i=1;i<=n;i++)//处理环形情况
        {
            if(i+m-1<=n)
            sum=bean[i+m-1]-bean[i-1];
            else
            sum=bean[n]-bean[i-1]+bean[i+m-n-1]-bean[0];
            if(sum>msum)
                msum=sum;
        }
        printf("%d\n",msum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值