poj 1068 Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16462 Accepted: 9839

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

      题目大意。记录括号序列有两种方式。p方式。记录第i个右括号前有多少个左括号。w方式。记录从左到右第i个右括号和与之配对的左括号之间有多少个右括号。包括自己


#include <stdio.h>

int main()
{
    int t,n,i,j,temp,pre,c,cc;//t,n如题意。temp临时读数据
    int par[50];//通过p序列还原出括号
    int w[25];//用于存w序列
    scanf("%d",&t);
    while(t--)
    {
        c=cc=0;//初始化
        pre=0;
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d",&temp);
            if(temp!=pre)//判断左括号是否增多。若增多则记录多的左括号
            {
                for(j=0; j<temp-pre; j++)
                    par[c++]=-1;//-1代表左括号
                pre=temp;//记录当前左括号总数
            }
            par[c++]=1;记录完左括号后记录右括号
        }
     //   for(i=0;i<c;i++)
     //       printf("%d ",par[i]);//用于检查记录是否正确
           for(i=0;i<c;i++)
           {
               if(par[i]==1)//遍历。先找到右括号
               {
                   temp=1;//temp用于计数
                   for(j=i-1;j>=0;j--)
                   {
                       if(par[j]==-1)//若遇到与右括号配对的左括号就进行下一次查找
                       {
                           par[j]=0;//已配对。删除左括号防止干扰一次查找
                           break;
                       }
                       if(par[j]==1)//记录其中包含右括号的对数
                        temp++;
                   }
                   w[cc++]=temp;
               }
           }
           for(i=0;i<cc;i++)
            printf("%d ",w[i]);
           printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值