问题描述 :
对于顺序存储的线性表,使用vector或数组,实现直接选择排序算法,并输出每趟的排序结果。
参考函数原型:(vector版本)
//直接选择排序
template<class ElemType>
void SimpleSelectSort( vector<ElemType> &A );
输入说明 :
第一行:顺序表A的数据元素的数据类型标记(0:int,1:double,2:char,3:string)
第二行:待排序顺序表A的数据元素(数据元素之间以空格分隔)
输出说明 :
如第一行输入值为0、1、2、3之外的值,直接输出“err”
否则:
第一行:第一趟的排序结果(数据元素之间以","分隔)
第三行:第二趟的排序结果(数据元素之间以","分隔)
...
第n行:最终的排序结果(数据元素之间以","分隔)
输入范例 :
0
21 25 49 25 16 8
输出范例 :
8,25,49,25,16,21
8,16,49,25,25,21
8,16,21,25,25,49
8,16,21,25,25,49
8,16,21,25,25,49
思路:
基本思想:每经过一趟比较就找出一个最小值,与待排序列最前面的位置互换即可。
首先,在n个记录中选择最小者放到R[1]位置;然后,从剩余的n-1个记录中选择最小者放到R[2]位置;…如此进行下去,直到全部有序为止。优点:实现简单
缺点:每趟只能确定一个元素,表长为n时需要n-1趟
前提:顺序存储结构时间效率: O(n²)——虽移动次数较少,但比较次数仍多。
空间效率: O(1)——没有附加单元(仅用到1个temp)
算法的稳定性:不稳定——因为排序时,25*到了25的前面。
代码实现:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <iomanip>
#include <stdlib.h>
#include <cmath>
#include <vector>
#include <sstream> //用于ostringstream、istringstream、stringstream这三个类
#include<stack>
#include<vector>
#include<queue>
#define ArraySize 100
using namespace std;
template<class ElemType>
void createvector( vector<ElemType> &A )
{
ElemType tmp;
string temp;
getline(cin,temp);
stringstream input(temp); //输入流
while(input>>tmp)
A.push_back(tmp);
}
//直接选择排序
template<class ElemType>
void SimpleSelectSort( vector<ElemType> &A ){
int length=A.size();
if(length==1){
cout<<A[0]<<endl;
}
else{
for(int i=0;i<length-1;i++){
int min=i+1;
for(int j=i+1;j<length;j++){
if(A[j]<A[min])
min=j;
}
if(A[min]<A[i]){
ElemType temp=A[min];
A[min]=A[i];
A[i]=temp;
// cout<<A[min]<<"和"<<A[i]<<"交换"<<endl;
}
for(int k=0;k<length-1;k++)
cout<<A[k]<<',';
cout<<A[length-1]<<endl;
}
}
}
int main()
{
int kd;
cin>>kd;
cin.ignore();
if(kd==0){
vector<int> A;
createvector( A );
SimpleSelectSort( A );
}
else if(kd==1){
vector<double>A;
createvector( A );
SimpleSelectSort( A );
}
else if(kd==2){
vector<char>A;
createvector( A );
SimpleSelectSort( A );
}
else if(kd==3){
vector<string >A;
createvector( A );
SimpleSelectSort( A );
}
else
cout<<"err"<<endl;
return 0;
}