Elevator

FJNU.1976

Description
有一座电梯,它的性能如下:上升一层需要6秒钟,下降一层需要4秒钟,如果要让它停下,它会停5秒钟。现在告诉你它要按顺序到达然后停靠的N个楼层,求它需要的时间。电梯开始在0层,楼梯共有100层。

Input
第一行为N(N<=50),接下来的N行是它N个停靠的楼层。

Output
只有一行,为所需要的时间。

Sample Input
1
2

3
2
3
1

Sample Output
17

41

Source
2007'福建师范大学低年级学生程序设计大赛

My Program

#include < iostream >
using   namespace  std;

int  main()
{
    
int N,i,x=0;
    
int t[55],s=0;
    cin
>>N;
    
for(i=0;i<N;i++)
        cin
>>t[i];
    
for(i=0;i<N;i++)
    
{
        
if(t[i]>s)
            x
+=(t[i]-s)*6+5;
        
else
            
if(t[i]<s)
                x
+=(s-t[i])*4+5;
            
else
                x
+=5;
        s
=t[i];
    }

    cout
<<x<<endl;
    
return 0;
}

YOYO's Note: 
第一次在现场比赛中做出的题目~增激动……超简单随便模拟一下不到十分钟就AC了 Orz...

C++源代码 注重类的交互 片段 #include using namespace std; #include "elevator.h" //Elevator class definition #include "person.h" //Person class definition #include "floor.h" //Floor class definition //constants that represent time required to travel //between floors and direction of the elevator const int Elevator::ELEVATOR_TRAVEL_TIME = 5; const int Elevator::UP = 0; const int Elevator::DOWN = 1; //constructor Elevator::Elevator( Floor &firstFloor, Floor &secondFloor) : elevatorButton( * this ), currentBuildingClockTime( 0 ), moving( false ), direction( UP ), currentFloor( Floor::FLOOR1 ), arrivalTime( 0 ), floor1NeedsService( false ), floor2NeedsService( false ), floor1Ref( firstFloor ), floor2Ref( secondFloor ), passengerPtr( 0 ) { cout << "elevator constrcuted" <<endl; }// end Elevator constructor //destructor Elevator::~Elevator() { delete passengerPtr; cout << "elevator destructed" << endl; }//end Elevator destructor //give time to elevator void Elevator::processTime( int time ) { currentBuildingClockTime = time; if ( moving ) //elevator is moving processPossibleArrival(); else processPossibleDeparture(); if ( !moving ) cout << "elevator at rest on floor " << currentFloor << endl; }// end function processTime // when elevator is moving, determine if it should stop void Elevator::processPossibleArrival() { //if elevator arrives at destination floor if ( currentBuildingClockTime == arrivalTime ) { currentFloor = ( currentFloor == Floor::FLOOR1 ? Floor::FLOOR2 : Floor::FLOOR1); //update current floor direction = ( currentFloor == Floor::FLOOR1 ? UP : DOWN ); //update direction cout << "elevator arrives on floor " << currentFloor <<endl; // process arrival at currentFloor arriveAtFloor( currentFloor == Floor::FLOOR1 ? floor1Ref : floor2Ref); return; }//end if //elevator still moving cout << "elevator moving " << ( direction == UP ? "UP" : "DOWN"
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值