hdu 2514 Another Eight Puzzle 枚举

将8个数字填进图中,让相邻的点上的数字不相邻,8个数字全排列枚举即可

要注意全排列的求法

#include<algorithm>

do{
…………
     }

while(next_permutation(a,a+8));


Another Eight Puzzle

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1

Problem Description
Fill the following 8 circles with digits 1~8,with each number exactly once . Conntcted circles cannot be filled with two consecutive numbers.
There are 17 pairs of connected cicles:
A-B , A-C, A-D
B-C, B-E, B-F
C-D, C-E, C-F, C-G
D-F, D-G
E-F, E-H
F-G, F-H
G-H

Filling G with 1 and D with 2 (or G with 2 and D with 1) is illegal since G and D are connected and 1 and 2 are consecutive .However ,filling A with 8 and B with 1 is legal since 8 and 1 are not consecutive .

In this problems,some circles are already filled,your tast is to fill the remaining circles to obtain a solution (if possivle).
 

Input
The first line contains a single integer T(1≤T≤10),the number of test cases. Each test case is a single line containing 8 integers 0~8,the numbers in circle A~H.0 indicates an empty circle.

 

Output
For each test case ,print the case number and the solution in the same format as the input . if there is no solution ,print “No answer”.If there more than one solution,print “Not unique”.
 

Sample Input
  
  
3 7 3 1 4 5 8 0 0 7 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0
 

Sample Output
  
  
Case 1: 7 3 1 4 5 8 6 2 Case 2: Not unique Case 3: No answer
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int a[8]={1,2,3,4,5,6,7,8};
int b[8];
int pos[8];
int p;
int cot;
int flag;
int end[8];
void judge()
{
	int i,j,f=0;
	for(i=0;i<p;i++)
	{
		if(a[i]!=b[pos[i]])
		{
			f=1;
			break;
		}
	}
	if(f)
		return;
	if(a[0]-a[1]==-1||a[0]-a[1]==1)
		return;
	if(a[0]-a[2]==-1||a[0]-a[2]==1)
		return;
	if(a[0]-a[3]==-1||a[0]-a[3]==1)
		return;
	if(a[1]-a[2]==-1||a[1]-a[2]==1)  //B C
	return;
	if(a[1]-a[4]==-1||a[1]-a[4]==1)  //	B E
		return;
	if(a[1]-a[5]==-1||a[1]-a[5]==1)  //B  F
		return;
	if(a[2]-a[3]==-1||a[2]-a[3]==1)   //C  D
	return;
	if(a[2]-a[4]==-1||a[2]-a[4]==1)   //C  E
		return;
	if(a[2]-a[5]==-1||a[2]-a[5]==1)  //C  F
		return;
	if(a[2]-a[6]==-1||a[2]-a[6]==1)   //C  G
	return;
	if(a[3]-a[5]==-1||a[3]-a[5]==1)  // D  F
		return;
	if(a[3]-a[6]==-1||a[3]-a[6]==1)  //D  G
		return;
	if(a[4]-a[5]==-1||a[4]-a[5]==1)  // E F
	return;
	if(a[4]-a[7]==-1||a[4]-a[7]==1)  //E H
		return;
	if(a[5]-a[6]==-1||a[5]-a[6]==1)  //F  G
		return;
	if(a[5]-a[7]==-1||a[5]-a[7]==1)  //F H
		return;
	if(a[6]-a[7]==-1||a[6]-a[7]==1)  //G H
		return;
	flag=1;
	cot++;
	if(cot==1)
	{
		for(i=0;i<8;i++)
			end[i]=a[i];
	}
}





int main()
{
	int i,j,k,l;
	scanf("%d",&l);
	for(k=1;k<=l;k++)
	{
		memset(pos,-1,sizeof(pos));
		for(i=0;i<8;i++)
		{
			a[i]=i+1;
		}
		cot=0;
		flag=0;
		p=0;
		for(i=0;i<8;i++)
		{
			scanf("%d",&b[i]);
			if(b[i]!=0)
			{
				pos[p++]=i;
			}
		}
		do{
			if(cot==2)
				break;
			if(a[0]==7&&a[1]==3&&a[2]==1&&a[3]==4&&a[4]==5&&a[5]==8&&a[6]==6&&a[7]==2)
			{
				j=9;
			}
			judge();
		}while(next_permutation(a,a+8));
		printf("Case %d:",k);
		if(cot==1)
		{
			for(i=0;i<8;i++)
				printf(" %d",end[i]);
			printf("\n");
		}
		else if(cot==2)
		{
			printf(" Not unique\n");
		}
		else
		{
			printf(" No answer\n");
		}

	}
	return 0;
}
				


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值