[1002]: A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 281561 Accepted Submission(s): 54201

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define N 1005

int common(int a, int b){
    if(a<b){
        return a;
    }
    else{
        return b;
    }
}
int rest(int a, int b){
    int temp;
    if(b>a){
        temp = b; 
        b = a;
        a = temp;
    }
    return (a-b-1);
}
int main()
{
    char num1[N], num2[N], sum1[N], sum2[N]; // num存储输入的数,sum存储结果 
    int n;

    while(scanf("%d", &n)!=EOF){ // n为要输入的行数 

        int k, i = 0, add=0;

        for(; i<n; i++){

            if(i){ // Output a blank line between two test cases.
                printf("\n");
            }

            scanf("%s%s", num1, num2);

            int len1 = strlen(num1); // 计算两个输入数的位数 
            int len2 = strlen(num2);

            int long1 = len1-1, long2 = len2-1; // 对应的下标 

            if( len1 >= len2 ){
                k = long2;
                for(; k>=0; k--){
                    sum2[k] = (num1[long1]-'0') + (num2[long2]-'0')+add;
                    if(sum2[k]>=10){
                        sum2[k] -= 10;
                        add = ((num1[long1]-'0' )+ (num2[long2]-'0')+add)/10;
                    }
                    else{
                        add = 0;
                    }
                    long1--;
                    long2--;
                }
                k = len1-len2-1;
                for(; k>=0; k--){
                    sum1[k] = (num1[k]-'0')+add;
                    if(sum1[k]>=10 && k>0){
                        sum1[k] -= 10;
                        add = ((num1[k]-'0')+add)/10;
                    } 
                    else{
                        add = 0;
                    }
                }
            }
            else{
                k = long1;
                for(; k>=0; k--){
                    sum2[k] = (num1[long1]-'0') + (num2[long2]-'0')+add;
                    if(sum2[k]>=10){
                        sum2[k] -= 10;
                        add = ((num1[long1]-'0' )+ (num2[long2]-'0')+add)/10;
                    }
                    else{
                        add = 0;
                    } 
                    long1--;
                    long2--;
                }
                k = len2-len1-1;
                for(; k>=0; k--){
                    sum1[k] = (num2[k]-'0')+add;
                    if(sum1[k]>=10 && k>0){
                        sum1[k] -= 10;
                        add = ((num2[k]-'0')+add)/10;
                    } 
                    else{
                        add = 0;
                    }
                }
            }
            int lenSum1 = rest(len1, len2);
            int lenSum2 = common(len1, len2);
            printf("Case %d:\n", i+1);
            printf("%s + %s = ", num1, num2);
            k = 0;
            for(; k<=lenSum1; k++){
                printf("%d", sum1[k]);
            }
            k = 0;
            for(; k<lenSum2; k++){
                printf("%d", sum2[k]);
            }
            printf("\n");
        }
    }
    return 0;
}

这里写图片描述
这里写图片描述
这里写图片描述

我的博客里面有两篇是关于这道题目的,主要是第一种思路是借鉴他人的(由于地址不明,所以没有注明),今天这种思路(个人解题结果:)是逆着第一种的思路

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值