node 版本与npm版本不相匹配

当查询npm版本时候报如下错误:
在这里插入图片描述
原因是 node 版本与npm版本不相匹配,两个东西需要使用想对应的版本号
cmd下输入命令:
node -v 查看node版本
npm -v 查看npm版本
再打开https://nodejs.org/zh-cn/download/releases/ 这个地址查看本地node版本对应哪个npm版本
在这里插入图片描述
因为我之前本地有7.5.3的npm版本了,根据下面绿色字体提示输入

npm install -g npm@7.5.6

命令来更新所需npm版本

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页
实付 9.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值