Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12638 Accepted Submission(s): 9732
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1 2 3
Sample Output
1 10 11
//@auther Yang Zongjun
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
const int MAXN = 105;
const int INF = 2100000000;
int n;
int a[MAXN];
int main()
{
// freopen("C:/Users/Administrator/Desktop/input.txt", "r", stdin);
while(~scanf("%d", &n))
{
//memset(a, 0, sizeof(a));
int t = n, cnt = 0;
while(t != 0)
{
int temp = t % 2;
a[cnt] = temp;
cnt++;
t = t / 2;
}
for(int i = cnt - 1; i >= 0; i--)
{
printf("%d", a[i]);
}
printf("\n");
}
return 0;
}