gradle eclipse下构建ssh2项目

这次构建主要遇到的问题:
1. 依赖脚本编写问题,对顶层包来说,有的被‘依赖’包是可选的,如果项目中要用到被依赖包,要显视配置进来,因为gradle依赖管理里面可选包不会被下载。我遇到的是spring-aop可选依赖aspectjweaver;

2.xml 的 xmlns 相关编写:这里的问题有些莫名奇妙,编写好配置文件后运行总是报错,无法解析。然后代码内容完全没变,把原来的一个换行给去掉了就行了。从
<beans 《换行》xmlns="http://www.springframework.org/schema/beans"  到<beans xmlns="http://www.springframework.org/schema/beans"

3. gradle build的时候编码错了:用的默认配置,然后,原来默认配置编码是GBK,项目编码格式是UTF-8,乱码了,解决办法,在build.gradle中加入:[compileJava, compileTestJava]*.options*.encoding = 'UTF-8'

4. web.xml下配置spring核心配置文件地址问题:
<context-param>
    <param-name>contextConfigLocation</param-name>
    <param-value>/WEB-INF/classes/applicationContext*.xml</param-value>
  </context-param>
这样子,在eclipse下用tomcat运行没错,但是用gradle jetty或者是tomcat插件就提示错了。其实gradle下没有WEB-INF,改成这样子就没问题了:
<context-param>
    <param-name>contextConfigLocation</param-name>
    <param-value>classpath:applicationContext*.xml</param-value>
  </context-param>
阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yangbo2921946188/article/details/49935045
上一篇windows下常用命令
下一篇gradle 参考资料
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭