UVALive:Argus

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 

Description

Download as PDF

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: “Every five minutes, retrieve the maximum temperature over the past five minutes.” Query-2: “Return the average temperature measured on each floor over the past 10 minutes.”

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of “#”.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005
 

解题报告:

            大意是一个系统在不同时间进行注册命令。输入两个整数num以及time。num为编号,time为注册周期。执行k次,打印出num,若时间点相同,则打印出num小的数值

           使用优先队列,压入队列时通过自定义条件判断决定压入的位置。

            弹出k次,每次弹出时,将弹出的指令+周期,更新下一次的打印时间。

参考代码:

#include <iostream>
#include<cstdio>
#include<queue>
using namespace std;
struct Item{
int Q_num,Q_time,Q_p;
bool operator <(const Item& a)const{
return  Q_time>a.Q_time||(Q_time==a.Q_time&&Q_num>a.Q_num);
}
};
priority_queue<Item> pq;
int main()
{
   //freopen("in.txt","r",stdin);
   char str[10];
   int time,num,k;
    while(cin>>str&&str[0]!='#')
    {
        cin>>num>>time;
        Item it;
        it.Q_num=num;
        it.Q_time=time;
        it.Q_p=time;
        pq.push(it);
    }

    cin>>k;

    while(k>0)
    {
        k--;

        Item it;
        it=pq.top();
        cout<<it.Q_num<<endl;
        it.Q_time+=it.Q_p;//更新下一次事件触发的时间
        pq.pop();
        pq.push(it);
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值