杭电acm hdu-1060Leftmost Digit

                     Leftmost Digit解答

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12972    Accepted Submission(s): 4966


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
2
2


  
  
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2
  1. 设n的n次方==x*10的a次方则
  2. n*㏒n=㏒x+a      a是n㏒n的整数部分,㏒x是他的小数部分
  3. ㏒x=n*㏒n-a      且a=(int)n㏒n
  4. ㏒x=n*㏒n-(int)n*㏒n下面就好懂了
  5. 代码如下
  6.  
  7.  
  8. #include<stdio.h>
    #include<math.h>
    int main()
    {
        __int64 cas,b,i,d;
        double a,m,n,c;
        scanf("%I64d",&cas);
        for(i=1;i<=cas;i++)
        {
            scanf("%lf",&n);
            a=n*log10(n);
            b=(__int64)a;
            c=a-b;
            d=(__int64)(pow(10,c));
            printf("%I64d\n",d);
        }
        return 0;
    }
    


     
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值