vue版本以及webpack版本

版权声明:关于安安 https://blog.csdn.net/yangluan999/article/details/79980275

vue作为大前端的主流框架 更新速度也是极快。

那么vue的更新会有哪些问题呢?最近在搭建vue框架的时候发现由于vue版本的快速迭代已经与原本般配的webpack产生了隔阂。webpack作为大前端的主流打包工具 如果与之不兼容,会有越来越多的麻烦事情。

经过反复测试,得出结论一篇 vue与webpack最佳拍档组合版本号公布。

npm init
npm install webpack@3.10.0 vue@2.5.13 vue-loader@13.3.0
npm install css-loader@0.28.7 vue-template-compiler@2.5.13
npm run build
npm install style-loader@0.19.1 url-loader@0.6.2 file-loader@1.1.6
npm install stylus-loader@3.0.1 stylus@0.54.5
npm install cross-env@5.1.3
npm run dev
webpack安装依赖包稳定版本:
vue-loader:13.6.0
webpack:3.10.0
vue:2.5.13
vue-template-compiler:2.5.13
css-loader:0.28.7
url-loader:0.6.2
style-loader:0.19.1
file-loader:1.1.6
stylus:0.54.5
stylus-loader:3.0.1
webpack-dev-server:2.9.7
cross-env:5.1.3
html-webpack-plugin:2.30.1

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页