数据结构实验之链表二:逆序建立链表
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
输入
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
第二行依次输入N个整数,逆序建立单链表。
输出
依次输出单链表所存放的数据。
示例输入
10 11 3 5 27 9 12 43 16 84 22
示例输出
22 84 16 43 12 9 27 5 3 11
提示
不能使用数组!
来源
示例程序
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(int n)
{
struct node *head,*p;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
return head;
}
int main()
{
struct node *head,*p;
int n,i;
scanf("%d",&n);
head=creat(n);
p=head->next;
for(i=0;i<n-1;i++)
{
printf("%d ",p->data);
p=p->next;
}
printf("%d",p->data);
return 0;
}