描述
有一个集合M是这样生成的: (1) 已知 k 是集合 M 的元素; (2) 如果 y 是 M 的元素,那么, 2y+1 和 3y+1 都是 M 的元素; (3) 除了上述二种情况外,没有别的数能够成为 M 的一个元素。
问题:任意给定 k 和 x,请判断 x 是否是 M 的元素。这里的 k是无符号整数,x 不大于 100000, 如果是,则输出YES,否则,输出 NO
输入
输入整数 k 和 x, 逗号间隔。
输出
如果是,则输出 YES,否则,输出NO
样例输入
0,22
样例输出
YES
来源
元培-From Whf
#include <bits/stdc++.h>
using namespace std;
struct node{
string ns;
int num=0;
};
int main()
{
int n,len,nlen,j;
string s,subs;
vector<node> no;
node t;
scanf("%d\n",&n);
getline(cin,s);
len = s.size();
for(int i=0;i<=len-n;i++)
{
subs = s.substr(i,n);
nlen = no.size();
for(j=0;j<nlen;j++)
{
if(subs == no[j].ns)
{
no[j].num++;
break;
}
}
if(j==nlen)
{
t.ns = subs;
t.num = 1;
no.push_back(t);
}
}
nlen = no.size();
for(int i=0;i<nlen;i++)
{
for(int j=0;j<nlen-i-1;j++)
{
if(no[j].num<no[j+1].num){
swap(no[j].num,no[j+1].num);
swap(no[j].ns,no[j+1].ns);
}
}
}
if(no[0].num<=1)
{
cout<<"NO\n";
}else{
cout<<no[0].num<<endl;
cout<<no[0].ns<<endl;
for(int i=1;i<nlen;i++)
{
if(no[i].num == no[i-1].num)
{
cout<<no[i].ns<<endl;
}else{
break;
}
}
}
return 0;
}