HDU 1060 Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15816    Accepted Submission(s): 6170


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1018  1061  1071  1573  1066 
今天下午周赛遇到这道题, 想了好久都没想出来,晚上就搜了一下题解,感觉解题方法好巧妙啊,大神就是大神。
计算N^N结果的最左边的数            
  数学题 由sum=N^N,两边对10取对数,log10(sum)=Nlog10(N),有sum=10^(Nlog10(N));
  由于10的整数次幂首位均为1,则仅需考虑Nlog10(N)的结果的小数部分即可


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	__int64 n,sum2;
	double m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d",&n);
		double sum1=n*log10(double(n));
		sum2=(__int64)sum1;
		sum1-=sum2;
		n=(__int64)pow(10.0,sum1);
		printf("%I64d\n",n);
	}
	return 0;
 } 



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值