HDU 2277 Change the ball(找规律)

Change the ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 643    Accepted Submission(s): 231


Problem Description
Garfield has three piles of balls, each pile has unique color of following: yellow, blue, and red. Now we also know Garfield has Y yellow balls, B blue balls, and R red balls. But Garfield just wants to change all the balls to one color. When he puts two balls of different color togather, the balls then change their colors automatically into the rest color. For instance, when Garfield puts a red one and a yellow one togather, the two balls immediately owns blue color, the same to other situations. But the rule doesn’t work when the two balls have the same color.
  Garfield is not able to estimate the minimal steps to achieve the aim. Can you tell him?

 

Input
For each line, there are three intergers Y, B, R(1<=Y,B,R<=1000),indicate the number refered above.
 

Output
For each case, tell Garfield the minimal steps to complete the assignment. If not, output the symbol “):”.
 

Sample Input
  
  
1 2 3 1 2 2
 

Sample Output
  
  
): 2
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2273  2276  2274  2279  2275 
题意:给出3种颜色小球的数目,两种不同颜色的小球能可以变为另一种颜色的小球,问能 否转化为一种小球,最少需要几步
分两种情况,第一种有两种小球的数目一样可以,第二种两种小球的数目之差为三的倍数
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int a[4];
	while(scanf("%d%d%d",&a[1],&a[2],&a[3])!=EOF)
	{
		sort(a+1,a+4);
		if(a[1]==a[2]||(a[2]-a[1])%3==0)
		printf("%d\n",a[2]);
	    else if(a[1]==a[3]||a[2]==a[3]||(a[3]-a[1])%3==0||(a[3]-a[2])%3==0)
		printf("%d\n",a[3]);
		else
		printf("):\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值