HDU 5640 King's Cake

King's Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 963    Accepted Submission(s): 681


Problem Description
It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1n,m10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.
 

Input
The first line contains a number T(T1000) , the number of the testcases.

For each testcase, the first line and the only line contains two positive numbers n,m(1n,m10000) .
 

Output
For each testcase, print a single number as the answer.
 

Sample Input
  
  
2 2 3 2 5
 

Sample Output
  
  
3 4 hint: For the first testcase you can divide the into one cake of $2\times2$ , 2 cakes of $1\times 1$
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5674  5673  5672  5671  5670 
题意:给出一个矩形,问最多能切成多少个正方形
不断地用长边减去短边,直到长边和短边相等。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int m,n,t,minn,maxx;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		int sum=1;
		maxx=max(n,m);
		minn=min(n,m);
		while(minn!=maxx)
		{
			
			minn=min(maxx-minn,minn);
			maxx=max(maxx-minn,minn);
			sum++;
		}
		printf("%d\n",sum);
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值