LightOJ 1138 Trailing Zeroes (III)

C - Trailing Zeroes (III)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题意:求末尾有Q个0,的N的阶乘,求N的最小值。

这里要用要用到一个定理

令F(x)表示正整数X末尾0个数,则有

当0<n<5时, f(n!)=0;

当N>=5时,f(n!)=k+f(k!),其中k=n/5;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define LL long long 
using namespace std;
LL sum(LL n)
{
	LL ans=0;
	while(n)
	{
		ans+=n/5;
		n=n/5;
	}
	return ans;
}
int main()
{
	LL p;
	int k=1;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&p);
		LL left=1;
		LL right=1000000000000;
		LL ans=0;
		while(right>=left)
		{
			LL mid=(right+left)/2;
			if(sum(mid)==p)
			{
				ans=mid;
				right=mid-1;
			}
			else if(sum(mid)>p)
			{
				right=mid-1;
			}
			else
			left=mid+1;
		}
		printf("Case %d: ",k++);
		if(ans)
		printf("%lld\n",ans);
		else
		printf("impossible\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值