POJ 3614 Sunscreen(贪心+优先队列)

Sunscreen
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7131 Accepted: 2518

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2

Source

题意:有C头牛要进行日光浴,每头牛都有一定的阳光承受范围minSPF i到maxSPFi,  现在有L种防晒霜,每种防晒霜可以将日光固定到SPFi,每种防嗮霜的数量为coveri,问最多有多少牛可以沐浴到合适的阳光

思路:要用优先队列来维护牛的最大承受能力,先让最小承受能力符合的进队列,让最大承受能力小的先出队列,其

他的牛可以选择其他的防晒霜
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
struct node1
{
	int left,right;
 } t1[2600];
 struct node2
 {
 	int score;
 	int num;
 }t2[2600];
bool cmp1(node1 a,node1 b)
{
	return a.left<b.left;
}
bool cmp2(node2 a,node2 b)
{
	return a.score<b.score;
}
int main()
{
	int n,m,i,j,k,l;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		scanf("%d%d",&t1[i].left,&t1[i].right);
		for(i=0;i<m;i++)
		scanf("%d%d",&t2[i].score,&t2[i].num);
		sort(t1,t1+n,cmp1);
		sort(t2,t2+m,cmp2);
		priority_queue<int ,vector<int>,greater<int> >q;//优先队列来维护牛的
		//最大承受阳光的能力 
		j=0;
		int ans=0;
		for(i=0;i<m;i++)
		{
			while(j<n&&t1[j].left<=t2[i].score)//然后最小承受能力满足的进队列 
			{
				q.push(t1[j].right);
				j++;
			}
			while(!q.empty()&&t2[i].num)
			{
				int now=q.top();//让最大承受能力最小的出队列 
				q.pop();
				if(now>=t2[i].score)
				{
					ans++;
					t2[i].num--;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值