POJ 1011 Sticks (经典DFS)

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 137449 Accepted: 32363

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source

所谓的经典就是不断的进行减枝操作
#include <stdio.h>
#include <algorithm>
#include<string.h>
using namespace std;
int str[65];
int used[65];
int n,len;
bool cmp(int a,int b)
{ 
    return a>b; 
}
bool dfs(int i,int l,int t)//i为当前试取的棍子序号,l为要拼成一
//根完整的棍子还需要的长度,t初值为所有棍子总长度 
{
    if(l==0)//此段搜索完毕 
    {
        t-=len;
        if(t==0)
		return true;
        for(i=0;used[i];++i);            //剪枝1:搜索下一根大棍子的时候,
		//找到第一个还没有使用的小棍子开始
        used[i]=1;                           //由于排序过,
		//找到的第一根肯定最长,也肯定要使用,所以从下一根开始搜索
        if(dfs(i+1,len-str[i],t))
		return true;
        used[i]=0;//回溯 
        t+=len;
    }
    else
    {
        for(int j=i;j<n;++j)
        {
            if(j>0&&(str[j]==str[j-1]&&!used[j-1]))  //剪枝2:前后
			//两根长度相等时,如果前面那根没被使用,也就是由前面那根
                continue;                                                //开始搜索不
				//到正确结果,那么再从这根开始也肯定搜索不出正确结果
                                                                                  
            if(!used[j]&&l>=str[j])   //剪枝3:
			//要拼成一根大棍子还需要的长度L>=当前小棍子长度,才能选用                           
            {
                l-=str[j];
                used[j]=1;
                if(dfs(j,l,t))
				return true;
                l+=str[j];
                used[j]=0;
                if(str[j]==l)    //剪枝4:
				//若本次的小棍长度刚好填满剩下长度
				//但是后面的搜索失败,则应该返回上一层
                    break;           
            }
        }
    }
    return false;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        int sum=0;
        for(int i=0;i<n;++i)
        {
        	scanf("%d",&str[i]);
            sum+=str[i];
            used[i]=0;
        }
        sort(str,str+n,cmp);   //剪枝5:从大到小排序后可大大减少递归次数
        bool flag=false;
        for(len=str[0];len<=sum/2;++len)   //剪枝6:大棍长度一定是所有
		//小棍长度之和的因数,且最小因数应该不小于小棍中最长的长度
        {
            if(sum%len==0)     
            {
                if(dfs(0,len,sum))
                {
                    flag=true;
                    printf("%d\n",len);
                    break;
                }
            }
        }
        if(!flag)
        printf("%d\n",sum);
    }
    return 0;
}
 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值