UVA 1388 Graveyard

Graveyard

Programming contests became so popular in the year 2397 that the governor of New Earck -- the largest human-inhabited planet of the galaxy -- opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input 

The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n-- the number of holographic statues initially located at the ACM, and m -- the number of statues to be added (2 id="iframe_0.39702277653850615" src="data:text/html;charset=utf8,%3Cimg%20id=%22img%22%20src=%22https://icpcarchive.ecs.baylor.edu/external/37/3708img1.png?_=2951588%22%20style=%22border:none;max-width:810px%22%3E%3Cscript%3Ewindow.onload%20=%20function%20()%20%7Bvar%20img%20=%20document.getElementById('img');%20window.parent.postMessage(%7BiframeId:'iframe_0.39702277653850615',width:img.width,height:img.height%7D,%20'http://www.cnblogs.com');%7D%3C/script%3E" frameborder="0" scrolling="no" style="border-style: none; border-width: initial; width: 20px; height: 20px;">n id="iframe_0.3942063779104501" src="data:text/html;charset=utf8,%3Cimg%20id=%22img%22%20src=%22https://icpcarchive.ecs.baylor.edu/external/37/3708img1.png?_=2951588%22%20style=%22border:none;max-width:810px%22%3E%3Cscript%3Ewindow.onload%20=%20function%20()%20%7Bvar%20img%20=%20document.getElementById('img');%20window.parent.postMessage(%7BiframeId:'iframe_0.3942063779104501',width:img.width,height:img.height%7D,%20'http://www.cnblogs.com');%7D%3C/script%3E" frameborder="0" scrolling="no" style="border-style: none; border-width: initial; width: 0px; height: 0px;">1000, 1 id="iframe_0.45512294420041144" src="data:text/html;charset=utf8,%3Cimg%20id=%22img%22%20src=%22https://icpcarchive.ecs.baylor.edu/external/37/3708img1.png?_=2951588%22%20style=%22border:none;max-width:810px%22%3E%3Cscript%3Ewindow.onload%20=%20function%20()%20%7Bvar%20img%20=%20document.getElementById('img');%20window.parent.postMessage(%7BiframeId:'iframe_0.45512294420041144',width:img.width,height:img.height%7D,%20'http://www.cnblogs.com');%7D%3C/script%3E" frameborder="0" scrolling="no" style="border-style: none; border-width: initial; width: 0px; height: 0px;">m id="iframe_0.7172756348736584" src="data:text/html;charset=utf8,%3Cimg%20id=%22img%22%20src=%22https://icpcarchive.ecs.baylor.edu/external/37/3708img1.png?_=2951588%22%20style=%22border:none;max-width:810px%22%3E%3Cscript%3Ewindow.onload%20=%20function%20()%20%7Bvar%20img%20=%20document.getElementById('img');%20window.parent.postMessage(%7BiframeId:'iframe_0.7172756348736584',width:img.width,height:img.height%7D,%20'http://www.cnblogs.com');%7D%3C/script%3E" frameborder="0" scrolling="no" style="border-style: none; border-width: initial; width: 0px; height: 0px;">1000) . The length of the alley along the park perimeter is exactly 10 000 feet.

 

Output 

For each test case, write to the output a line with a single real number -- the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Sample Input

2 1

2 3

3 1

10 10

Sample Output

1666.6667

1000.0

1666.6667

0.0

题目大意:在一个周长为10000的园上等距分布着n个雕塑。现在又有m个雕塑加入,希望所有 m+n个雕塑在圆周上均匀分布。这就需要移动其中一些原有的雕塑。要求n个雕塑移动的总距离尽量少

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	double k,l,s1,s2,sum,a[1100],b[1100];
	int i,j,n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		sum=0.0;
		k=10000.0/(n+m);
		l=10000.0/n;
		s1=k;
		s2=l;
		for(i=0;i<n+m;i++)
		a[i]=i*k;
		for(i=0;i<n;i++)
		b[i]=i*l;
		int cnt=1;
		for(i=1;i<n;i++)
		{
//			if(a[i]>b[cnt])
//			{
//				sum+=min(fabs(a[i]-b[cnt]),fabs(b[cnt]-a[i-1]));
//				cnt++;
//			}
//			if(cnt==n)
//			break;
            while(s1<=s2)
            {
            	s1+=k;
			}
			sum+=min(s1-s2,s2-s1+k);
			s2+=l;
		}
		printf("%.4lf\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值