POJ 3276 Face The Right Way (反转)

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4649 Accepted: 2159

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For  K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

题意:N头牛排成一列,或前或后,现在有一台机器,每次可以设定一个K值,,没操作一次,可以使连续的K头牛反转。现在要使所有的牛面向前方。求为了让所有的女都面向前方需要操作的最小次数以及对应的最小的K值。
思路:反转问题,把所有的K都求解一次,对于每一个K,都从左到右考虑一下N头牛的情况。需要反转的话flag[i] =区间 i 到 i+k -1 ,反转的话为1,否则为0;这样在考虑第i头牛时,只需要考虑之前反转过的次数。如果为奇数,则这头牛的反向与起始方向相同,否则相反。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[5100], n, flag[5100];
int solve(int k)
{
	memset(flag, 0, sizeof(flag));
	int i, j;
	int sum = 0;
	int cnt = 0;
	for(i = 1; i <= n - k + 1; i++)
	{
		if(i - k>=1)
		{
			sum -= flag[i-k];
		}
		if(a[i] ==0 && sum % 2 ==0)
		{
			flag[i] = 1;
			cnt++;
			sum +=flag[i];
		}
		else if(a[i] == 1 && sum % 2 !=0)
		{
			flag[i] = 1;
			cnt++;
			sum +=flag[i];
		}
	}
	for(i; i <=n; i++)//剩下的牛是否还需要反转 
	{
		if(i - k >=1)
		{
			sum -= flag[i-k];
		}
		if(a[i] == 0 &&sum % 2 ==0)
		return -1;
		else if(a[i] == 1&& sum % 2 != 0)
		return -1;
	}
	return cnt;
}
int main()
{
	int i, k, m;
	char s[3];
	while(scanf("%d", &n)!=EOF)
	{
		m = 10010000;
		for(i = 1; i <= n; i++)
		{
			scanf("%s",s);
			if(s[0] == 'B')
			a[i] = 0;
			else
			a[i] = 1;
		}
		k = 1;
		for(i = 1; i <= n; i++)
		{
			int mid = solve(i);
			if(mid==-1)
			{
				continue;
			}
			else if(m > mid)
			{
				m = mid;
				k = i;
			}
		}
		printf("%d %d\n", k, m);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值