POJ 2353 Ministy 动态规划 双向DP

Ministry
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4520Accepted: 1451Special Judge

Description

Mr. F. wants to get a document be signed by a minister. A minister signs a document only if it is approved by his ministry. The ministry is an M-floor building with floors numbered from 1 to M, 1<=M<=100. Each floor has N rooms (1<=N<=500) also numbered from 1 to N. In each room there is one (and only one) official. 

A document is approved by the ministry only if it is signed by at least one official from the M-th floor. An official signs a document only if at least one of the following conditions is satisfied: 
a. the official works on the 1st floor; 
b. the document is signed by the official working in the room with the same number but situated one floor below; 
c. the document is signed by an official working in a neighbouring room (rooms are neighbouring if they are situated on the same floor and their numbers differ by one).

Each official collects a fee for signing a document. The fee is a positive integer not exceeding 10^9. 

You should find the cheapest way to approve the document. 
 

Input

The first line of an input file contains two integers, separated by space. The first integer M represents the number of floors in the building, and the second integer N represents the number of rooms per floor. Each of the next M lines contains N integers separated with spaces that describe fees (the k-th integer at l-th line is the fee required by the official working in the k-th room at the l-th floor).

Output

You should print the numbers of rooms (one per line) in the order they should be visited to approve the document in the cheapest way. If there are more than one way leading to the cheapest cost you may print an any of them.

Sample Input

3 4
10 10 1 10
2 2 2 10
1 10 10 10

Sample Output

3
3
2
1
1

Hint

You can assume that for each official there always exists a way to get the approval of a document (from the 1st floor to this official inclusively) paying no more than 10^9. 
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
题目大意:有一栋m层的房子,每层n个房间,如果该房间在第一层或者该房间的上一层的房间或者左右任意一个房间被访问才能访问该房间,问从第一层到最后一层走过的房间的权值和最小的路径。注意:在同一行中要么是过单点,即向下转移,要么是一条往左的路,要么是一条往右的路,不会在一层中先往左(右),后往右(左).
状态转移方程:
上下两层:dp[i][j] = dp[i+1][j]+a[i][j];
从左往右:dp[i][j] = dp[i][j-1]+a[i][j];
从右往左:dp[i][j] = dp[i][j+1]+a[i][j];
<span style="font-size:24px;">#include <iostream>
#include <cstring>
#include <cstdio>
#include <climits>
using namespace std;
#define M 101
#define N 501
int dp[M][N];
int a[M][N];
int path[M][N];

int main()
{
    int m, n;
    int i, j;
    scanf("%d%d",&m,&n);
    for(i=1; i<=m; i++)
        for(j=1; j<=n; j++)
            scanf("%d",&a[i][j]);
    memset(dp,0,sizeof(dp));
    memset(path,0,sizeof(path));
    for(j=1; j<=n; j++)
        dp[m][j] = a[m][j];
    for(i=m-1; i>0; i--)
    {
        for(j=1; j<=n; j++)
        {
            dp[i][j] = dp[i+1][j]+a[i][j];
            path[i][j] = j;
            if(j>1 && dp[i][j-1]+a[i][j]<dp[i][j])
            {
                dp[i][j] = dp[i][j-1]+a[i][j];
                path[i][j] = j-1;
            }
        }
        for(j=n-1; j>0; j--)
        {
            if(dp[i][j+1]+a[i][j]<dp[i][j])
            {
                dp[i][j] = dp[i][j+1]+a[i][j];
                path[i][j] = j+1;
            }
        }
    }


    int minn = INT_MAX;     //INT_MAX是int所能表示的最大数
    int index = 0;
    for(j=1; j<=n; j++)     //查找第一行最小的一列
    {
        if(minn > dp[1][j])
        {
            minn = dp[1][j];
            index = j;
        }
    }
    printf("%d\n",index);
    i = index;
    int k = 1;
    while(path[k][i])
    {
        printf("%d\n",path[k][i]);
        if(path[k][i] == i)
            k++;
        else
            i = path[k][i];
    }
    return 0;
}</span>

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值